Project

General

Profile

Bug #9993

dt lock while writing XMP on files on mount point

Added by Pascal Obry over 5 years ago. Updated over 5 years ago.

Status:
Closed: won't fix
Priority:
Medium
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
06/22/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Ok, all this makes no sense to me but tracking this down here is what I do observed reliably.

When I export image to local storage I have no problem.
When I export image to a network mount point dt locks. This is 100% reproducible on my side.

Tracking this down to dt_exif_xmp_attach (in src/common/exif.cc).

If I comment out "img->writeMetadata();" just before the return all is well and the image is always exported. Or if I comment out "img->readMetadata();" (~ 10 lines above) the export is ok too.

As I said all this makes no sense to me, at least the point where it locks above does not seems to be the issue. Again I don't have this behavior when exporting on local storage. Could be some kind of memory leak?

Does this ring a bell? Is someone else reproducing?

BTW, I have libexiv2-dev 0.23 on my GNU/Linux box.

History

#1 Updated by Pascal Obry over 5 years ago

  • Status changed from New to Closed: won't fix

I have updated to exiv2 0.24 from experimental branch on my Debian box and this issue vanished! So probably an exiv2 issue.

Also available in: Atom PDF

Go to top