Project

General

Profile

Feature #9939

Darkroom: larger-increment hotkeyable increase/decrease actions for Exposure and White Balance temperature

Added by Ralf Brown over 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Start date:
05/03/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

In addition to the current bindable actions with increments corresponding to mouse-wheel movements, there should also be versions with larger increments that would be more appropriate for hotkeys, e.g. 1/3 EV or 100 Kelvin. Alternatively, if Lua scripting is ever extended to controlling modules in darkroom, bindable scripts could be added to perform the equivalent actions.

Relevant module shortcuts:
image operations|exposure|exposure|decrease
image operations|exposure|exposure|increase
image operations|white balance|temperature|decrease
image operations|white balance|temperature|increase


Related issues

Is duplicate of darktable - Feature #8944: Increase Mouse Wheel Increments for ExposureFixed09/23/2012

History

#1 Updated by Ralf Brown over 5 years ago

  • % Done changed from 0 to 70
  • Status changed from New to Patch attached

See pull request #621.

#2 Updated by Roman Lebedev over 5 years ago

  • bitness set to 64-bit
  • System set to all
  • Affected Version set to git development version
  • % Done changed from 70 to 20
  • Status changed from Patch attached to Incomplete

We do not want this to be implemented in the core.
Once Lua can deal with IOPs, it will certainly be Lua territory.

#3 Updated by Roman Lebedev almost 5 years ago

  • Is duplicate of Feature #8944: Increase Mouse Wheel Increments for Exposure added

#4 Updated by Roman Lebedev almost 5 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Duplicate

Also available in: Atom PDF

Go to top