Project

General

Profile

Bug #9880

darktable-cli is confused by TIFF file extension during export

Added by Torsten Bronger about 6 years ago. Updated over 3 years ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
Category:
General
Target version:
Start date:
03/30/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

darktable-cli needs a .tiff file extension for the output file in order to recognise that it is supposed to create a TIFF file. .tif is not recognised. However then, it produces a .tif file.

prepare_panorama_20mm.xmp (4.95 KB) prepare_panorama_20mm.xmp Torsten Bronger, 03/30/2014 11:22 PM
dsc04804.arw (24.1 MB) dsc04804.arw Torsten Bronger, 03/30/2014 11:22 PM

Associated revisions

Revision 4691674d (diff)
Added by Roman Lebedev about 6 years ago

Workaround fix for issue #9880

History

#1 Updated by Torsten Bronger about 6 years ago

It is reproduced here with the attached files and:

darktable-cli dsc04804.arw prepare_panorama_20mm.xmp dsc04804.tiff

#2 Updated by Roman Lebedev about 6 years ago

  • % Done changed from 0 to 20
  • Assignee set to Roman Lebedev
  • Status changed from New to Incomplete

Sub-issue 1: darktable-cli needs a .tiff file extension for the output file in order to recognise that it is supposed to create a TIFF file. .tif is not recognised
Is fixed in commit 4691674

Sub-issue 2: However then, it produces a .tif file
Either both GUI and CLI will overwrite file extension, or they both will not do so.
And since this has been previously discussed and decided as WONTFIX, i think it should also be WONTFIX.

#3 Updated by Tobias Ellinghaus over 3 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: won't fix

Closing as this is quite old and not going to change.

#4 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top