Project

General

Profile

Bug #9841

Export using style: only one instance of module applied

Added by René Kowalke about 5 years ago. Updated over 1 year ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
03/05/2014
Due date:
% Done:

0%

Affected Version:
1.4.1
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When you select a style during export and the selected style contains multiple instances of the same module only one instance is applied to output. Here attached style contains two instances of profiled denoise:

  1. NLM with blending mode 'HSV luminance'
  2. Wavelets with blending mode 'HSV color'

Output of darktable -d perf (German, look for "Entrauschen (Profil)"):

[export] creating pixelpipe took 0,227 secs (0,244 CPU)
[dev_pixelpipe] took 0,180 secs (0,137 CPU) initing base buffer [export]
[dev_pixelpipe] took 0,037 secs (0,059 CPU) processing `Weißabgleich' [export]
[dev_pixelpipe] took 0,019 secs (0,062 CPU) processing `Spitzlicht-Rekonstruktion' [export]
[dev_pixelpipe] took 0,042 secs (0,087 CPU) processing `Tote Pixel' [export]
[dev_pixelpipe] took 0,195 secs (0,714 CPU) processing `Entrastern' [export]
[dev_pixelpipe] took 25,068 secs (96,718 CPU) processing `Entrauschen (Profil)' [export]
[dev_pixelpipe] took 2,439 secs (9,012 CPU) processing `Objektivkorrektur' [export]
[dev_pixelpipe] took 0,107 secs (0,385 CPU) processing `Basiskurve' [export]
[dev_pixelpipe] took 0,111 secs (0,417 CPU) processing `Eingabefarbprofil' [export]
[dev_pixelpipe] took 1,019 secs (3,611 CPU) processing `Schatten und Spitzlichter' [export]
[dev_pixelpipe] took 12,643 secs (42,996 CPU) processing `Equalizer' [export]
[dev_pixelpipe] took 0,262 secs (0,902 CPU) processing `Schärfen' [export]
[dev_pixelpipe] took 0,178 secs (0,660 CPU) processing `Ausgabefarbprofil' [export]
[dev_pixelpipe] took 0,061 secs (0,192 CPU) processing `Gamma' [export]
[dev_process_export] pixel pipeline processing took 43,711 secs (157,301 CPU)

Comparing noise reduction in output JPG it looks like only style's lowest instance was applied (doublechecked by switching content of instances).

When you apply same style directly in darkroom the output is correct:

[export] creating pixelpipe took 0,224 secs (0,226 CPU)
[dev_pixelpipe] took 0,181 secs (0,105 CPU) initing base buffer [export]
[dev_pixelpipe] took 0,039 secs (0,068 CPU) processing `Weißabgleich' [export]
[dev_pixelpipe] took 0,019 secs (0,035 CPU) processing `Spitzlicht-Rekonstruktion' [export]
[dev_pixelpipe] took 0,046 secs (0,094 CPU) processing `Tote Pixel' [export]
[dev_pixelpipe] took 0,192 secs (0,711 CPU) processing `Entrastern' [export]
[dev_pixelpipe] took 25,224 secs (96,764 CPU) processing `Entrauschen (Profil)' [export]
[dev_pixelpipe] took 8,778 secs (28,474 CPU) processing `Entrauschen (Profil)' [export]
[dev_pixelpipe] took 2,444 secs (9,008 CPU) processing `Objektivkorrektur' [export]
[dev_pixelpipe] took 0,107 secs (0,391 CPU) processing `Basiskurve' [export]
[dev_pixelpipe] took 0,111 secs (0,413 CPU) processing `Eingabefarbprofil' [export]
[dev_pixelpipe] took 1,141 secs (4,118 CPU) processing `Schatten und Spitzlichter' [export]
[dev_pixelpipe] took 11,956 secs (43,544 CPU) processing `Equalizer' [export]
[dev_pixelpipe] took 0,269 secs (0,936 CPU) processing `Schärfen' [export]
[dev_pixelpipe] took 0,182 secs (0,649 CPU) processing `Ausgabefarbprofil' [export]
[dev_pixelpipe] took 0,058 secs (0,192 CPU) processing `Gamma' [export]
[dev_process_export] pixel pipeline processing took 52,095 secs (186,850 CPU)

I also checked what happens if you mix up instances, e.g. put default module instance to stack and instance #1 to style. Then also only one instance is applied. Output JPG looks like only style's instance is applied.

Denoise ISO 800+.dtstyle - Style to be applied during export (contains two instances of profiled denoise module) (950 Bytes) René Kowalke, 03/05/2014 07:35 PM

DSC_3012.NEF.xmp (6.55 KB) René Kowalke, 03/05/2014 07:35 PM

DSC_3012.NEF (16.7 MB) René Kowalke, 03/05/2014 07:52 PM

History

#1 Updated by Serge Gavrilov about 4 years ago

The bug is still reproducible with 1.6.3

#2 Updated by Huy Hoang over 1 year ago

This ticket can probably be closed. Multiple instances of module are being applied from style (at least for 2.2.5 and current master). The instances are just being added to the style in the wrong order (see #11768).

#3 Updated by Tobias Ellinghaus over 1 year ago

  • Status changed from New to Closed: invalid

#4 Updated by Roman Lebedev over 1 year ago

  • Target version set to 2.4.0

Also available in: Atom PDF