Project

General

Profile

Bug #9819

Darktable 1.4.1 deletes export presets

Added by Roman Standzikowski over 6 years ago. Updated almost 6 years ago.

Status:
Fixed
Priority:
High
Category:
Lighttable
Start date:
02/16/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.4.1
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Steps:
- I have been using Darktable since some time and had few export presets (lighttable > export selected)
Darktable was upgraded to version 1.4.1 (from 1.4.0)
- after selecting export preset, it gets deleted immediately, without any warning (not OK and highly irritating)

System: Gentoo Linux, AMD64

log.txt.gz (6.26 KB) log.txt.gz Console logs Roman Standzikowski, 02/18/2014 07:24 PM
library.db.gz (18.3 KB) library.db.gz Database Roman Standzikowski, 02/18/2014 07:24 PM

History

#1 Updated by Pascal de Bruijn over 6 years ago

  • Target version set to Candidate for next patch release

Can you reproduce this issue when running darktable from a terminal? Could you provide us with the terminal output?

If you're not seeing anything relevant, running darktable -d sql might help...

#2 Updated by Roman Standzikowski over 6 years ago

Regular output is empty - see the attachment for '-d sql' log. I have also attached sample library (empty, no photos) - open it with 1.4.1 and try to select export preset and it will be deleted.

#3 Updated by Pascal de Bruijn over 6 years ago

  • % Done changed from 0 to 10
  • Status changed from New to Confirmed

Thanks. The sample database is very helpful, I can reproduce.

#4 Updated by Roman Lebedev almost 6 years ago

  • % Done changed from 10 to 100
  • Assignee set to Tobias Ellinghaus
  • Status changed from Confirmed to Fixed

Support for legacy_params to libs & imageio was added in a83845392e33e82a700d4bdb8c9380c3b5680de6, so in the future this should not happen again.

Also available in: Atom PDF

Go to top