Project

General

Profile

Bug #9744

GUI hangs during a session, threads in the gdb stacktrace.

Added by Attila Gróf about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Critical
Assignee:
-
Category:
Lighttable
Start date:
12/25/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

This is what happened before the gui hung.

1. Using dt for roughly 30 min. Importing and editing several files
2. I left the machine for several hours.
3. Continued the session with executing a lua script that groups several images.
4. Ungrouped several of the groups created by the lua script.

I have attached the stack trace. It contains 187 threads.

DT does not use any cpu. It must be a deadlock.

History

#1 Updated by Attila Gróf about 6 years ago

Sorry I was wrong. DT uses 74% of a single CPU core while the gui is not responding.
dt version is 1.4rc1+120~gee46e3d

#2 Updated by Ulrich Pegelow about 6 years ago

  • Status changed from New to Duplicate

Atila,

I suspect that the root cause is the same as your issue #9710; let's continue disucssion there.

Also available in: Atom PDF

Go to top