Project

General

Profile

Bug #9708

autosaving history

Added by Michal Fapso over 5 years ago. Updated over 5 years ago.

Status:
Closed: won't fix
Priority:
Medium
Assignee:
-
Category:
Darkroom
Start date:
12/05/2013
Due date:
% Done:

0%

Affected Version:
git development version
System:
Ubuntu
bitness:
32-bit
hardware architecture:
amd64/x86

Description

I was working with the 1.4rc1 version for about an hour when darkroom crashed. I can not reproduce it and even wouldn't mind that crash at all if the operations history of the image I was working on is not lost. It would be great if all changes are auto-saved and thus any work can be seamlessly resumed even after a crash.

Sorry if this was already reported, I did not find it.

P.S.: 1.4 is really a wonderful release anyway! Thanks for your hard work!

History

#1 Updated by Ulrich Pegelow over 5 years ago

  • Status changed from New to Closed: won't fix

Well, if you think about it then this is not really feasible, although the wish is understandable. A crash is caused by a software error that could sit and wait
in any place of our code. As we don't know when and where it will happen we would need to store all data to disk all the time just to be prepared. This would slow
down darktable in a way that users would rather switch to some other software.

Nope, the better way is hunting bugs and trying to fix as many of them as possible. With continuing development a crash should be less and less likely. And
judging from darktable's development we seem to be moving in the right direction :)

#2 Updated by Michal Fapso over 5 years ago

Thanks for your reply, Ulrich. Sure, I see, a bug-free application is the ultimate goal :o) But what about autosaving the history only of the current picture say every 30 seconds or so. I am sure it would not harm the performance, since the xmp files have only few kilobytes. I was editing one picture for about 20 minutes when darktable crashed, so any kind of autosave would really help. Maybe it would be even possible with a Lua script?

#3 Updated by Tobias Ellinghaus over 5 years ago

The problem is that the crash might be due to an invalid parameter in a module or a bug in a mask. If we auto-saved we would propagate this buggy value to the stored data and make it impossible to ever load it again (unless you discard the history stack) since just opening it would bring back the settings that made darktable crash. It might even be that you won't be able to start darktable any more in this case (for example when darktable tries to process the image on startup to generate a thumbnail). The problems inherent to this are way worse than eventually losing your edit, knowing it and having a clean start.

#4 Updated by Michal Fapso over 5 years ago

Ok, you're right, Tobias. Then it is really better not to auto save :o)

Also available in: Atom PDF