Project

General

Profile

Bug #9668

Issue with using dt with tablet input

Added by Arvind Pinto over 5 years ago. Updated over 5 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
11/04/2013
Due date:
% Done:

0%

Affected Version:
git development version
System:
openSUSE
bitness:
64-bit
hardware architecture:
amd64/x86

Description

How to reproduce:

1) Plugin a graphic tablet and load a RAW file
2) Go and activate the brush/masking tool (It's easier to notice the issue with it)
3) Minimise darktable, switch apps and go back to dt
4) The mouse responds to the 4 panels on the side and the module sliders. It does not respond to any on canvas events. Hovering the mouse over the canvas makes the brush appear to freeze. The cursor however now responds only to tablet input. Moving the pen on the tablet seems to unfreeze the cursor. If the tablet is unplugged when dt is up and running at this stage it leads to a darktable crash.

Expected behaviour:
DT should seamlessly switch between mouse and tablet input

Actual behaviour:
The mouse responds to the 4 panels on the side and the module sliders. It does not respond to any on canvas events. Hovering the mouse over the canvas makes the brush appear to freeze. The cursor however now responds only to tablet input. Moving the pen on the tablet seems to unfreeze the cursor. If the tablet is unplugged when dt is up and running at this stage it leads to a darktable crash.

Which tablet was used:
A wacom bamboo pen and touch was used (touch functionality disabled) though it should be reproducible on any other graphics tablet. Not sure about UCLogic devices as they don't have proper driver support on linux.

Which distribution:
Using Suse 12.3 (KDE)

Which version:
git master - compiled from source (1.3+1298~g008edcd)

Side Note:
I noticed that using print screen seems to unfreeze the cursor weirdly enough. I can't explain why print screen seems to have this unintended side effect.

History

#1 Updated by Ulrich Pegelow over 5 years ago

  • Priority changed from High to Low

Nope, can't confirm even though I have almost the identical system setup including Linux distribution and graphics tablet.
I can easily move from mouse to pen and back at any time. Maybe an issue with your xorg settings where the roles of input devices
like mouse and graphics tablet are defined.

#2 Updated by Ulrich Pegelow over 5 years ago

@TO: any further information on this topic? Please report back in the next few days so we can close the ticket.

#3 Updated by Ulrich Pegelow over 5 years ago

  • Status changed from New to Closed: upstream

If at all this is an upstream issue either in gtk or in the X server setup.

Also available in: Atom PDF