Project

General

Profile

Bug #9596

Soft proofing seems not to work as expected

Added by Alexander Demmler almost 5 years ago. Updated almost 5 years ago.

Status:
Incomplete
Priority:
Low
Category:
Darkroom
Target version:
-
Start date:
09/28/2013
Due date:
% Done:

20%

Affected Version:
1.2.3
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Dear Pascal,

I have read all your articles about CMM on Linux and darktable. I have also made the out of gammut test "G" and there I see "cyan" aereas.
But still for my impression whatever I configure in darktable has no influence on what is displayed.

Example:
1. Open sRGB testimage
2. Configure: Rendering Intents, Outputprofile: sRGB, Softproofprofile: ISO Coated V2

Here I get "Non supported profile" message. ISO coated V2 is an CMYK profile - it should work - or not?

cmm.pdf - color management workflow (18.7 KB) Alexander Demmler, 11/24/2013 10:29 AM

color_flowchart.pdf (46.4 KB) Tobias Ellinghaus, 11/24/2013 03:34 PM

History

#1 Updated by Tobias Ellinghaus almost 5 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete
  • Assignee deleted (Pascal de Bruijn)

I hope you are aware that 1.1.3 is ANCIENT? Please update to 1.2.3 and see if your problems still exist. If yes, then tell us what your problems are. If it's just that the CMYK profile doesn't work as an output profile: no idea if that's supposed to work.

#2 Updated by Alexander Demmler almost 5 years ago

HI,

thx for your quick response. Sorry for this inconveniance.
I am using Linux Mint (Ubuntu based) Version 15 and 1.13 is the package they provide.
Seems like I need to compile from the scratch and do cross checking than.
or can I use the origin Ubuntu packages?

thx again Alexander

#3 Updated by Alexander Demmler almost 5 years ago

  • Assignee set to Pascal de Bruijn

So far I installed Pascals PPA and got darktable 1.2.3 (Ubuntu Rairing) running.
The issue still exists. Choosing a soft proof profile does not influence the "view" at all.

#4 Updated by Alexander Demmler almost 5 years ago

After further tesing I found out that CMYK profiles get accepted after activating Outputprofile and "basic curve" from "further modules" tab.
The colors have changed once. But still the display does not change if I swap now between different CMYK profiles. The "use lcms" option from settings is activated.

#5 Updated by Ulrich Pegelow almost 5 years ago

ISO coated should work as a softproof profile. In order to activate softproofing you need to press the 's' key. You best do it when the "output color" module is active.

#6 Updated by Ulrich Pegelow almost 5 years ago

Of course I meant ... when that module is in focus.

#7 Updated by Tobias Ellinghaus almost 5 years ago

So, is there anything not working as intended?

#8 Updated by Alexander Demmler almost 5 years ago

Yes it does not work as CMM should work, from my point of view and experience.
I will write a longer report about it - but not today.

thx for aksing

#9 Updated by Tobias Ellinghaus almost 5 years ago

Good, because I am not sure that I understand what the actual problem is. :D

#10 Updated by Ulrich Pegelow almost 5 years ago

  • bitness set to 64-bit

Anything new about this topic? Please report back in the next few days so we can close the ticket.

#11 Updated by Alexander Demmler almost 5 years ago

Sorry I was on a trip and could not work on this.
I will provide you a clear sketch how cmm should be done next week.
Please give me some time for preparation. thx Alexander

#12 Updated by Tobias Ellinghaus almost 5 years ago

  • Target version deleted (1.2.2)
  • Affected Version changed from 1.1.3 to 1.2.3
  • Assignee deleted (Pascal de Bruijn)

I am really excited what I will learn.

#13 Updated by Pascal de Bruijn almost 5 years ago

  • Subject changed from Colormanagement seems not to work to Soft proofing seems not to work as expected

#14 Updated by Tobias Ellinghaus almost 5 years ago

  • Priority changed from Medium to Low

Any updates? There isn't much time left to fix bugs for the next release.

#15 Updated by Alexander Demmler almost 5 years ago

  • File cmm.pdf added
  • Assignee set to Tobias Ellinghaus
  • Target version set to Candidate for next major release

Hi to all,

attached a first sketch of a suitable color management workflow for applications.
For correct processing you need informations and sources of
source profile, target profile, monitor profile in case of CMYK2CMYK transfer a device link profile.
Most of it is present in dark table - so I am shure it is more a "conceptual problem".

All the needed conversions can be done with lcms.

Please ask if there are still questions. For a professional usage in graphic industry this feature is mandatory. thx in advance!

#16 Updated by Tobias Ellinghaus almost 5 years ago

  • System changed from Ubuntu to all
  • % Done changed from 20 to 0
  • File color_flowchart.pdf added
  • Status changed from Incomplete to Closed: invalid

Hello,

first let me thank you for your effort and excuse for the long reply to follow. I drew a quick sketch of how darktable's colour management currently works. Maybe that will make some things clear.

One thing you will notice is that there is no such thing as a working profile for most parts because we try to do as much as possible in Lab space which allows us to just ignore most of the difficulties with regard to profile gamuts and similar nastinesses. It's also a linear pipeline which represents physical light much better and should give nicer results (*).

Another thing you will notice is that the modules in the pipeline assume to see RGB data (let's ignore RAW files, they are the same once you are past ‘demosaic’ anyway). Since CMYK uses 4 values per pixel instead of the 3 seen for an RGB file this doesn't allow to load CMYK files in the first place. It might be possible to add a new code path to everything coming before ‘input color profile’ to handle that, too, but I don't think that editing CMYK files, which are mostly used in the preprint world, fits darktable's product vision.

Then there are the modules coming after ‘output color profile’ which work in RGB space again (*). Allowing to export CMYK files would require to change these modules to work on 4-valued data, too. Which we will not do since darktable advocates a late binding workflow. If you really need your image file separated into CMYK to manually fiddle with the plates then darktable can't help you with that task anyway, it's a photo workflow tool, not a preprint application. If however you just want your files to be transformed to CMYK using lcms2 then you should reconsider your general workflow, since once you have chosen one CMYK profile you are more or less locked in. Nowadays it's common to use a big RGB space like AdobeRGB for your to be printed pictures and let the RIP do the separation.

That being said there is still one place where CMYK can come into play and that is required for the aforementioned late binding workflow: softproofing. darktable allows you to use any (?) CMYK profile in ‘output color profile’ as the softproof profile to check what the final result would look like. In general you would want to use a device specific profile for that, your print house can probably provide it. You also want to do gamut checking to see if your wide gamut output profile (like AdobeRGB) is indeed wide enough to hold all your image data.

So, possible bugs left aside I think that darktable does exactly what it should do and don't think that anything should be changed with regard to colour management.

If you want to discuss this any further (which I would enjoy, maybe I am just not seeing your point) you should subscribe to our developers mailing list [0]. The bug tracker isn't the right place for this. After all, others might benefit from this, too.

(*) we want to move more plugins into Lab space in the future, so it's not perfect yet.

[0] https://lists.sourceforge.net/lists/listinfo/darktable-devel

#17 Updated by Alexander Demmler almost 5 years ago

Dear Tobias,

thx for your long explanation - sorry bit I do not agree totally with the concept in darktable.

1. I do not wantto separate to CMYK (this canbe done by many other tools), but a working preview would be needed
If you want to compare images with given prints or proofs, because those are made using CMYK processes.

2. Our aim is to find a application to manage and preview images before printing correctly
and asume needed manipulations. Actually ther is none - not even GIMP can do this.
Because image processing is mass processing darktable would have been the better choice.

3. From you text:
That being said there is still one place where CMYK can come into play and that is required for the aforementioned late binding workflow: softproofing. darktable allows you to use any (?) CMYK profile in ‘output color profile’ as the softproof profile to check what the final result would look like. In general you would want to use a device specific profile for that, your print house can probably provide it. You also want to do gamut checking to see if your wide gamut output profile (like AdobeRGB) is indeed wide enough to hold all your image data.

And exactly this is not working - darktable always says "wrong color space using RGB" ...

4. Instead of using LAB CS I would use a "calibrated RGB" otherwise color compression from LAB to CMYK is to big,
which results in an significant color shift.

.... however after 25 years in graphic industry as developer and consultant I know there is different believes and theories ...

I have argued here, because I did not wanted to start the discussion from scratch.

thx in advance

#18 Updated by Tobias Ellinghaus almost 5 years ago

  • Target version deleted (Candidate for next major release)
  • Status changed from Closed: invalid to Incomplete
  • % Done changed from 0 to 20

Alexander Demmler wrote:

Dear Tobias,

thx for your long explanation - sorry bit I do not agree totally with the concept in darktable.

That's ok. :)

1. I do not wantto separate to CMYK (this canbe done by many other tools), but a working preview would be needed
If you want to compare images with given prints or proofs, because those are made using CMYK processes.

What do you mean, softproofing or looking at the plates/channels to check for trapping, overprinting and similar things?

2. Our aim is to find a application to manage and preview images before printing correctly
and asume needed manipulations. Actually ther is none - not even GIMP can do this.
Because image processing is mass processing darktable would have been the better choice.

Well, I don't think that darktable should support any advanced CMYK workflow, just softproofing.

3. From you text:

That being said there is still one place where CMYK can come into play and that is required for the aforementioned late binding workflow: softproofing. darktable allows you to use any (?) CMYK profile in ‘output color profile’ as the softproof profile to check what the final result would look like. In general you would want to use a device specific profile for that, your print house can probably provide it. You also want to do gamut checking to see if your wide gamut output profile (like AdobeRGB) is indeed wide enough to hold all your image data.

And exactly this is not working - darktable always says "wrong color space using RGB" ...

It always worked for me. Could you please

  • share the CMYK profile that is not working
  • take a screenshot of the ‘output color profile’ module so I can check if you set everything up correctly?

If this doesn't work correctly it's a bug indeed.

4. Instead of using LAB CS I would use a "calibrated RGB" otherwise color compression from LAB to CMYK is to big,
which results in an significant color shift.

Why would color compression be too big? For one you will export to some RGB profile in the end anyway, and when processing the image you don't have to push the colors to use the full Lab color space. If you do it would give wrong results in your workflow, too, since it would clip during processing inside the pipe. Currently you have at least the possibility to bring colors back later in the pipe.

[...]

I have argued here, because I did not wanted to start the discussion from scratch.

We could have pasted the start of the discussion. I really prefer my mail client over some web browser text input.

thx in advance

Also available in: Atom PDF