Project

General

Profile

Bug #9592

darktable 1.3+1034~gf7ef17f crush on start

Added by Людмила Бандурина over 6 years ago. Updated over 6 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Start date:
09/25/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Darktable 1.3+1034~gf7ef17f from dev-repository crash on start after last update. Ubuntu 13.04 32 bit.

darktable_20130925_segfault_start.txt (38.6 KB) darktable_20130925_segfault_start.txt trace Людмила Бандурина, 09/25/2013 01:32 AM
IMG_6019.jpg (3.15 MB) IMG_6019.jpg Людмила Бандурина, 10/12/2013 01:06 AM
IMG_6016.CR2.xmp (104 KB) IMG_6016.CR2.xmp Людмила Бандурина, 10/12/2013 01:06 AM
IMG_6019.CR2.xmp (18.2 KB) IMG_6019.CR2.xmp Людмила Бандурина, 10/12/2013 01:06 AM
IMG_6019.CR2 (23.2 MB) IMG_6019.CR2 Людмила Бандурина, 10/12/2013 01:06 AM
IMG_6019_01.jpg (11.6 MB) IMG_6019_01.jpg Людмила Бандурина, 10/12/2013 01:06 AM
IMG_6023.jpg (3.29 MB) IMG_6023.jpg Людмила Бандурина, 10/12/2013 02:27 AM
IMG_6021.CR2.xmp (17.5 KB) IMG_6021.CR2.xmp Людмила Бандурина, 10/12/2013 02:27 AM
IMG_6023.CR2.xmp (20 KB) IMG_6023.CR2.xmp Людмила Бандурина, 10/12/2013 02:27 AM
IMG_6040.CR2.xmp (15.7 KB) IMG_6040.CR2.xmp Людмила Бандурина, 10/12/2013 02:27 AM
IMG_6042.CR2.xmp (13.6 KB) IMG_6042.CR2.xmp Людмила Бандурина, 10/12/2013 02:27 AM
darktable_20131012_segfault_darkroom_export.txt (23.8 KB) darktable_20131012_segfault_darkroom_export.txt Людмила Бандурина, 10/12/2013 02:27 AM

History

#1 Updated by Ulrich Pegelow over 6 years ago

Please download the latest darktable version as of yesterday. The should have been fixed already. Please report back.

#2 Updated by Ulrich Pegelow over 6 years ago

@TO: Any news on this issue? There have been some fixes recently and I would be interested to see if the problem is solved.

#3 Updated by Людмила Бандурина over 6 years ago

In version 1.3+1069~g79488d8 darktable not crush on start, but it have memory leaks (?)
First pic exporting quickly, second pic exporting slowly, and on third photo (if I use noise reduction and/or many masks) — I get message «Can't export, low memory».

#4 Updated by Tobias Ellinghaus over 6 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete
  • Are you exporting to disk or some other target?
  • Can you tell us which modules are enabled on the image that might cause the leak?
  • What happens when you only export the image that causes the error message and no others before? Maybe it's not a leak but one image consuming more than others?

#5 Updated by Людмила Бандурина over 6 years ago

  • Exporting to disk from darkroom (Ctrl+E).
  • Basically, the use of masks. Especially - many complex masks with the brush.
  • After darktable restarting the same image exported quickly (if I begin with it).

#6 Updated by Ulrich Pegelow over 6 years ago

Can you please supply an example? (XMP file which leads to the problems you describe)

#7 Updated by Людмила Бандурина over 6 years ago

Oh, another surprize — in the first file I use complex masks with brush (IMG_6016.CR2.xmp in attach). In the next file I use two path masks and similar settings (IMG_6019.CR2.xmp in attach). And result jpg is black & white negative (IMG_6019.jpg in attach)! After darktable restarting I get normal exported file (IMG_6019_01.jpg in attach).
Raw IMG_6019.CR2 in attach too.
Darktable 1.3+1105~g446d0bc from Darktable Unstable PPA. Exporting to disk from darkroom (Ctrl+E).

#8 Updated by Людмила Бандурина over 6 years ago

And in attach bt for crush on export fourth file from darkroom. Simple masks used. The first file (6021) is exported quickly. The second (6023) is much slower, and the result is a black-and-white negative. The third file is exported very quickly (6040, without masks). Fourth (6042) - crash at the start of export. XMPs and negative 6023 also attached.

#9 Updated by Ulrich Pegelow over 6 years ago

Well, I think the issue is caused by out-of-memory situations. You are running darktable on a 32-bit system.
As we point out in our usermanual this can quickly become a borderline case. See [[http://www.darktable.org/usermanual/ch07.html.php#darktable%20and%20memory]].

Processing complex masks involves a lot of dynamic memory allocations. Due to the limited address space of a 32-bit system this can lead to an effect called memory fragmentation. After a few export rounds less and less address space is available for large buffer allocations and finally darktable may even crash when an allocation fails.

You may try to optimize the relevant settings in core options. The mentioned usermanual section gives you some hints. Maybe you should try to reduce the cache size a bit. However, our general advice is as always to migrate to a 64-bit system, which solves all your memory related issues.

Ulrich

#10 Updated by Ulrich Pegelow over 6 years ago

Anything new on this topic? If not I will close it.

#11 Updated by Ulrich Pegelow over 6 years ago

  • % Done changed from 20 to 0
  • Priority changed from Critical to Low
  • Status changed from Incomplete to Closed: invalid

No news on this issue since a week. Let's close it unless the TO re-opens with further information.

Also available in: Atom PDF

Go to top