Project

General

Profile

Bug #9580

The metadata lens field is not recognized for Nikon 1 J3

Added by Andreas Schneider almost 5 years ago. Updated almost 5 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Lighttable
Start date:
09/10/2013
Due date:
% Done:

0%

Affected Version:
1.2.2
System:
openSUSE
bitness:
64-bit
hardware architecture:
amd64/x86

Description

The metadata lens field is empty for raw pictures taken with a Nikon 1 J3.

exiv2 correctly displays it:

Exif.Photo.LensModel Ascii 64 1 NIKKOR VR 10-30mm f/3.5-5.6

and also other Nikon specific data:

Exif.Nikon3.LensType Byte 1 VR
Exif.Nikon3.Lens Rational 4 10-30mm F3.5-5.6
Exif.Nikon3.LensFStops Undefined 4 8.66667

I will attach the RAW image.

DSC_0003.NEF (11.9 MB) Andreas Schneider, 09/10/2013 02:47 PM

1_NIKKOR_VR_10-30mm_f__3.5-5.6--10.0mm--5.NEF (9.73 MB) Berthold Crysmann, 09/13/2013 12:38 AM

1_NIKKOR_VR_30-110mm_f__3.8-5.6--30.0mm--5.NEF (9.26 MB) Berthold Crysmann, 09/13/2013 12:38 AM

History

#1 Updated by Pascal de Bruijn almost 5 years ago

This seems to work in our 1.1.x tree, so I'm guessing this is a regression. Further investigation needed.

#2 Updated by Berthold Crysmann almost 5 years ago

Dear all,

I can confirm this bug for Nikon 1 J1. Exiv2 lists my lenses correctly, yet in darktable the lens field is empty.
It seems quite important to get this right, since lens correction needs to know for 30mm focal length whether the picture was taken with the 10-30mm or the 30-110mm lens.

Just in case, I attach two .NEF files, one for each lens.

Cheers,

Berthold

Also available in: Atom PDF