Project

General

Profile

Bug #9564

Nex 3N Whitebalance wrong

Added by Paul Woitaschek almost 7 years ago. Updated almost 6 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
08/23/2013
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.2.2
System:
unknown
bitness:
64-bit
hardware architecture:
amd64/x86

Description

The whitebalance of Sony Nex 3N is totally wrong. I attached the .jpeg from camera, the raw from camera and a screenshot of importing the raw to darktable looks by default.

Bildschirmfoto von »2013-08-23 18_31_08«.png (798 KB) Bildschirmfoto von »2013-08-23 18_31_08«.png Paul Woitaschek, 08/23/2013 09:00 PM
DSC00161.ARW (15.8 MB) DSC00161.ARW Paul Woitaschek, 08/23/2013 09:00 PM
DSC00161.JPG (2.97 MB) DSC00161.JPG Paul Woitaschek, 08/23/2013 09:00 PM

History

#1 Updated by Pascal de Bruijn almost 7 years ago

It seems fine in the 1.1.x branch, so this is a regression in 1.2 and newer.

This commit might be involved:
https://github.com/darktable-org/darktable/commit/5668c8d14362d375a92d2b2290f0dd3a06058caf

Also, please consider submitting your camera's white balance presets, for more information please see:
http://www.darktable.org/2012/10/whats-involved-with-adding-support-for-new-cameras/

#2 Updated by Josef Wells over 6 years ago

I see the same with my RX100. I've been using Debian Sid packages.. so I'll get the source building again and see how it goes. I'll try reverting the commit Pascal mentioned as well..

Will report back.

#3 Updated by Josef Wells over 6 years ago

My build from the release-1.2.2 tag does not have the broken white-balance.

Pascal, did you try with your release 1.2.2, are you using your own build?

Maybe my build is different.. is there a build.sh log I can post?

#4 Updated by Josef Wells over 6 years ago

Latest Debian package does not exhibit this bug

Old version 1.2.2-1, new version 1.2.2-2.

Debian changelog notes libraw updates for a security vulnerability.. so I guess the problem was in libraw. Seems reasonable.

#5 Updated by Paul Woitaschek over 6 years ago

Josef Wells wrote:

Latest Debian package does not exhibit this bug

Old version 1.2.2-1, new version 1.2.2-2.

Debian changelog notes libraw updates for a security vulnerability.. so I guess the problem was in libraw. Seems reasonable.

Well for me still the same, although libraw update.

local/darktable 1.2.2-2
local/libraw1394 2.1.0-1

Anyway, is darktable really running with libraw? Libraw is no dependency of darktable, at least in arch. Btw, the little preview in Darktable at the bottom uses the right whitebanance.

#6 Updated by Tobias Ellinghaus over 6 years ago

Paul Woitaschek wrote:

Josef Wells wrote:

Latest Debian package does not exhibit this bug

Old version 1.2.2-1, new version 1.2.2-2.

Debian changelog notes libraw updates for a security vulnerability.. so I guess the problem was in libraw. Seems reasonable.

Well for me still the same, although libraw update.

local/darktable 1.2.2-2
local/libraw1394 2.1.0-1

Anyway, is darktable really running with libraw? Libraw is no dependency of darktable, at least in arch.

darktable ships its own copy of libraw with its sources and only uses that. A version that might be installed in the system is not used.

Btw, the little preview in Darktable at the bottom uses the right whitebanance.

With default settings the thumbnails are taken from the JPEG previews embedded into the RAW files by your camera. Once the image was processed by darktable (opened in darkroom, exported, ...) the preview is generated from the RAW and no longer from the camera processed JPEG.

#7 Updated by Josef Wells over 6 years ago

Debian applies patches to the libraw supplied with darktable, see:
http://packages.debian.org/sid/darktable

The diff from 1.2.2 to Debian's 1.2.2-2 is here:
http://ftp.debian.org/debian/pool/main/d/darktable/darktable_1.2.2-2.debian.tar.gz

I have not got back to test 1.2.2-1 since this upgrade.. it is possible another package upgrade did something, if there is interest I can try and see if I can still get the bug to manifest.

#8 Updated by Paul Woitaschek over 6 years ago

Updated to the newest version and it is fixed. N1 :)

#9 Updated by Roman Lebedev almost 6 years ago

  • bitness set to 64-bit
  • % Done changed from 0 to 100
  • Status changed from New to Fixed

Also available in: Atom PDF

Go to top