Project

General

Profile

Bug #9558

Lua52 - fedor 19 not work, fixed

Added by Jaroslav Tvrdy almost 7 years ago. Updated over 6 years ago.

Status:
Fixed
Priority:
Low
Category:
Lua
Start date:
08/17/2013
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
Fedora/RHEL
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello,
in fedora don't exist package Lua52, when i am upgrade Lua from 5.1 to 5.2.2 Lua find stupid non existing package Lua52-5.2 ... i am try create i package config and not work too.

I am rewrite Change Lua52 to Lua:
FindLua52.cmake
SET
SET
SET
SET

and now work (config find Lua), yes, maybe exist stupid distribution with Lua52. but normal is Lua, now is need FindLua52.cmake with detect Lua52 and Lua v 5.2 too

History

#1 Updated by Jaroslav Tvrdy almost 7 years ago

SET(LUA52_FIND_REQUIRED ${Lua_FIND_REQUIRED})
SET(LUA52_FIND_VERSION ${Lua_FIND_VERSION})
SET(LUA52_FIND_VERSION_EXACT ${Lua_FIND_VERSION_EXACT})
SET(LUA52_FIND_QUIETLY ${Lua_FIND_QUIETLY})

#2 Updated by Jérémy Rosen over 6 years ago

  • bitness set to 64-bit

Hello

is this bug still valid with the latest git version ? I think we fixed something related but I don't have a Fedora to test....

#3 Updated by Jaroslav Tvrdy over 6 years ago

Jérémy Rosen wrote:

Hello

is this bug still valid with the latest git version ? I think we fixed something related but I don't have a Fedora to test....

Yes,
Now work, i am delete my local darktable directory and transfer new GIT and work

-- checking for one of the modules 'lua5.2;lua'
-- Lua support: Enabled

Thanks

#4 Updated by Tobias Ellinghaus over 6 years ago

  • % Done changed from 0 to 100
  • Target version set to Candidate for next minor release
  • Status changed from New to Fixed

Also available in: Atom PDF

Go to top