Project

General

Profile

Bug #9544

Wavelet denoise reveals hotpixels limits

Added by Luis Fernandes about 6 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
08/03/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
git stable branch
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I shot some images after shooting some video, so the ensuing images had as expected hot pixels, more than normal.
This wasn't very noticeable under the chroma noise, but the hotpixels module managed to remove them.
However after applying wavelet denoise in "color" blend mode (which works wonders), all the hot pixels suddently became very prominent in the image.

no wavelet denoise, no hotpixels
no wavelet denoise, hotpixels applied
wavelet denoise, hotpixels applied

CR2 and DT XMP files here: http://www.4shared.com/archive/AdKfCV2-/shot_cr2.html

Just for the sake of curiosity i tried the same image in RawTherapee with the impulse noise filter, and with some tweaking it was more effective than DT's hotpixel.
Going to src/iop/hotpixels.c:115, and doubling the multiplier value however did improve things:

doubled multiplier, full strenght

But this would have the side effect of applying an excessive hotpixels removal on existing images.
I suppose changing the hotpixels order is not possible either since you would want to apply hotpixel removal in the earliest possible stage of the processing pipeline, is this correct?

Any suggestions to solve this problem?

Also available in: Atom PDF

Go to top