Project

General

Profile

Bug #9429

Import of cropped raw files from lightroom are upside down

Added by Benjamin Schindler almost 7 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
Category:
Darkroom
Start date:
05/19/2013
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.2
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I have a number of images which are imported upside down. I'm attaching an xmp which when imported makes the image go upside down here.

The image was shot in portrait, may be this is of relevance. I can attach the nef if required.

DSC_4232.xmp (3.14 KB) DSC_4232.xmp Benjamin Schindler, 05/19/2013 01:21 PM
DSC_4232.NEF (7.92 MB) DSC_4232.NEF Benjamin Schindler, 05/19/2013 05:28 PM

History

#1 Updated by Pascal Obry almost 7 years ago

  • Target version set to Candidate for next patch release
  • Assignee set to Pascal Obry
  • Category set to Darkroom

Yes, the raw will be needed. I suppose this is the same issue as #9423. If you are building from source you can try the fix-lr-import-orientation branch.

#2 Updated by Benjamin Schindler almost 7 years ago

Thatseems to go into the right direction, but it does not fully fix the problem.

I'm attaching the raw as well now. The image is now rotated by 90° (CCW)

#3 Updated by Pascal Obry almost 7 years ago

Ok, found the issue. My implementation/testing was based on portrait image without the exif proper information. So the orientation was applied twice when the corresponding exif information (as for your image) was present! I believe to have fixed this issue, and with a bit of luck that there is no regression. Can you test again the branch? Would be nice if you can test on multiple images (portrait and landscape) to be sure all is right now. Thanks.

#4 Updated by Benjamin Schindler almost 7 years ago

No, that does not work. The attached image is still rotated by 90°...

#5 Updated by Pascal Obry almost 7 years ago

Have you removed the image from the catalog? Have you removed the .NEF.xmp? Otherwise the importation of Lr data is not done. You must receive the message on the screen saying that such and such module have been imported.

#6 Updated by Benjamin Schindler almost 7 years ago

I'm trying very hard to delete the entire filmroll. Just had a larger chat with dt-devs trying to achieve this and it just didn't work...

What I then did to try it out is to just rename the folder, re-import and try again, which is why I said the image is still rotated. But may be my db needs a serious cleaning now...

btw... I'm bschindler|home in dt-irc if you want

#7 Updated by Pascal Obry almost 7 years ago

And what about the DSC_4232.NEF.xmp? Did you removed it? I don't see how it is possible that it is working on my side and not on yours :( And I just tested this again just now!

#8 Updated by Pascal Obry almost 7 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Fixed

Closing as this should be fixed.

Also available in: Atom PDF

Go to top