Project

General

Profile

Bug #9299

Wrong behavior of styles with multi-instance modules

Added by Roman Lebedev almost 7 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
-
Category:
General
Target version:
Start date:
03/17/2013
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Choose an image, discard history stack, duplicate.
Open original image in darkroom, enable "Denoise (Profiled)" with params: Mode: Non-Local Means, Blend mode: Lightness.
Create new instance of same module "Denoise (Profiled)" with different params: Mode: Wavelets, Blend mode: Color.
Switch to lighttable, create a style from the current history stack, include only "denoise (profiled)".
Open duplicate image (with empty history stack), apply newly created style.
There will be 2 instances of "Denoise (Profiled)", but only second will be enabled, and none of them will have correct params saved.

This bug is probably related to bug #9300


Subtasks

Bug #9300: DT hangs when applying styles with multi-instance modulesFixed

History

#1 Updated by Pascal Obry almost 7 years ago

Probably fixed too, see #9300.

#2 Updated by Pascal Obry almost 7 years ago

  • % Done changed from 0 to 10
  • Target version set to Future
  • Status changed from New to Confirmed
  • Category set to General

#3 Updated by Roman Lebedev almost 7 years ago

This one is mostly fixed.
The only issue i have noticed: after applying style (created as explained in bug description) to history-less image, profile list for second instance of "Denoise (Profiled)" does not automatically repopulated - i.e. 1-st instance have correct profile list, but 2-nd instance have empty profile list.
It's get repopulated after you switch to lighttable and back to darktable.

#4 Updated by Aldric Renaudin almost 7 years ago

Should be fixed in master now.
Can you test ?
Thanks

#5 Updated by Roman Lebedev almost 7 years ago

  • % Done changed from 10 to 100
  • Status changed from Confirmed to Fixed

Yes, i think it has been fixed.
Thanks.

Also available in: Atom PDF

Go to top