Project

General

Profile

Bug #9279

Darktable corrupts geotag data

Added by Torsten Bronger over 7 years ago. Updated over 6 years ago.

Status:
Fixed
Priority:
Medium
Category:
Map / Geolocation
Target version:
-
Start date:
02/25/2013
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

After having imported a directory with geotagged images (in XMP files), the geo locations are corrupted. The image attached has N264°00,901' and E094°07,533'. They used to be correct. Since this means data loss, I set the priority to high.

dsc09376.jpeg.xmp (3.57 KB) dsc09376.jpeg.xmp Torsten Bronger, 02/25/2013 06:11 PM
fix_geotags.py (799 Bytes) fix_geotags.py Torsten Bronger, 02/26/2013 04:23 AM
issue9279.tar (1.57 MB) issue9279.tar Directory for reproducing this issue Torsten Bronger, 02/26/2013 10:06 PM

History

#1 Updated by Torsten Bronger over 7 years ago

The original location of the image was something like 50.878838,7.122627 (Cologne-Bonn airport terminal).

#2 Updated by Torsten Bronger over 7 years ago

It's possibly a localization issue. FWIW, my computer is set to German.

#3 Updated by Torsten Bronger over 7 years ago

The attached Python3 script fixes the issue for existing XMP files. Please adjust the path to your XMP files before running the script.

#4 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 0 to 20
  • Priority changed from High to Medium
  • Assignee set to Tobias Ellinghaus
  • Status changed from New to Incomplete

I can see that the latitude and longitude are corrupted in your XMP (',' vs. '.') however I am not able to make darktable generate such a XMP file. I also use the German version of darktable. What are the language settings of your system? And what version of libexiv2 do you have installed?

I'm setting it back to Medium since it might be annoying but it's not corrupting the original image file.

#5 Updated by Torsten Bronger over 7 years ago

I use an off-the-shelf Lubuntu 12.10, exiv2 is 0.23. Only DT is compiled by me. $LANG is "de_DE.utf8".

I managed to reproduce the bug by doing this:

  1. Untar the attached tar file
  2. Call current git DT:
    darktable --library /tmp/library.db --configdir /tmp --cachedir /tmp /path/to/test_roll
    
  3. open test_roll/dsc09533.jpeg.xmp

There, you should see the broken geolocation values.

#6 Updated by Torsten Bronger over 6 years ago

It has always been difficult to reproduce for me, for some reason. I haven't experienced this problem for some time now. Maybe http://permalink.gmane.org/gmane.comp.graphics.darktable.devel/3499 fixed it for good?

#7 Updated by Tobias Ellinghaus over 6 years ago

  • % Done changed from 20 to 100
  • Status changed from Incomplete to Fixed

Yes, that should have fixed it.

Also available in: Atom PDF

Go to top