Project

General

Profile

Bug #9235

Chromatic Aberration correction not displayed

Added by P B over 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
02/03/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When enabling the correction of Chromatic Aberration, DT doesn't show any difference when switching it on/off. An exported picture shows some difference to what DT displays:
http://malenki.ch/d/2013-02-03_163730_scr.png
http://malenki.ch/d/2013-02-03_163846_scr.png

dscRX1000981.arw.xmp (12.8 KB) dscRX1000981.arw.xmp P B, 02/04/2013 01:48 PM
dscRX1000981.jpg (4.18 MB) dscRX1000981.jpg P B, 02/04/2013 01:48 PM
dscRX1000981.arw (20.2 MB) dscRX1000981.arw P B, 02/04/2013 01:48 PM
Zrzut ekranu z 2013-03-27 23_50_19.png (704 KB) Zrzut ekranu z 2013-03-27 23_50_19.png Mistrz Pan, 03/28/2013 12:50 AM

History

#1 Updated by Ulrich Pegelow over 7 years ago

Could you please supply an input image plus XMP file so we can try to reproduce?

File size for attachments is limited in redmine, but you can upload your RAW to some file hoster like dropbox and post a link here.

#2 Updated by Simon Spannagel over 7 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

#4 Updated by Ulrich Pegelow over 7 years ago

  • Affected Version changed from 1.1.2 to git development version
  • % Done changed from 20 to 10
  • Status changed from Incomplete to Confirmed

Hi,

I can confirm the issue. Module chromatic aberration does its job when it comes to export but has no visible effect in darkroom mode.

First thing to be said: we borrowed this module from rawtherapee. Frankly speaking I have only a very rough idea of its way of working. Most likely it is based on a model on how lateral chromatic aberrations are "constructed". They increase radially from center to the image corners. The module auto-generates the needed correction parameters by fitting its model to the real image (levenberg-marquardt fit or the like). This works well for file exports.

Now comes the problem. In darkroom view you will most likely try to inspect the module's effect when fully zoomed into the image. What the module now gets is not the full image but only the small part you see on the screen. The chromatic aberrations in that part will not follow the assumed radial model and the module just fails to derive any usable correction parameters.

This is a bit annoying as normally we want you to see what you get. But I fear that solving this issue might be really difficult.

One idea: we could try to derive the correction parameters from the preview/navigation window, which has the full image size. But then this image might be too low resolution to get a good fit...

#5 Updated by Ulrich Pegelow over 7 years ago

  • Target version set to Future

#6 Updated by Mistrz Pan about 7 years ago

I think it also considers version 1.1.4. But for me it appears as colourful error block with message in console:

$ darktable IMG_7599.CR2
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes
blockdenom vanishes

#7 Updated by Ognian Tsonev about 7 years ago

I have 1.2
I used the chromatic aberration on my images but it have no real difference in view as in exported images. The images tried are taken with 300mm lens.
I'm linking one of my raw files, xmp and an exported jpg.

[[https://docs.google.com/file/d/0B3aNcqCv9yS6dkJzUXdjMVctMWs/edit?usp=sharing]]
[[https://docs.google.com/file/d/0B3aNcqCv9yS6c01aYndhYkxvVGs/edit?usp=sharing]]
[[https://docs.google.com/file/d/0B3aNcqCv9yS6OWV2ZTBVVEVRQWs/edit?usp=sharing]]

#8 Updated by Ric Flomag almost 7 years ago

  • % Done changed from 10 to 0
  • Status changed from Confirmed to Duplicate

Marking as a duplicate of bug #8746, though that one does not report any difference between darkroom mode and exported images, but I suppose each one's experience differ depending of the sample image used.

Uploading another test case, if this can help... Anything else I can do to help correct this bug ? This is a show-stopper for me, as the only alternative left is to set my camera to record pictures as JPEG to avoid chromatic aberrations...

This is Darktable 1.3+740~g2c3d3a8

Keep up the amazing work in making darktable the best free software application available to photographers !

Also available in: Atom PDF

Go to top