Project

General

Profile

Bug #9183

Metadata alteration after image is processed by darktable

Added by Matthew Halbert over 7 years ago. Updated over 6 years ago.

Status:
Closed: invalid
Priority:
Medium
Assignee:
-
Category:
General
Target version:
-
Start date:
01/14/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When an image is processed by darktable and exported as a PNG or JPG, the metadata (image information) changes. This is in the development version on Ubuntu 12.10. Originally all metadata (ISO, f-stop, etc) is visible in Gnome Image Viewer 3.6.0 by opening the window in that program, right clicking properties, and viewing metadata (on both tabs). After proccessing by darktable, this information appears as blanks- i.e., exposure time will be listed as an option, but no value is associated with that category anymore. Running the processed photo through Exiftool shows that the information is still embedded, but somehow it has changed to possibly a non-standard format, as GIV can no longer get at the image information.

Image Properties_001_originalphoto_working.png (36.3 KB) Image Properties_001_originalphoto_working.png Matthew Halbert, 01/15/2013 01:30 AM
Image Properties_002_processedphoto_broken.png (27.4 KB) Image Properties_002_processedphoto_broken.png Matthew Halbert, 01/15/2013 01:30 AM
DSC_0040.JPG (5.75 MB) DSC_0040.JPG Matthew Halbert, 01/15/2013 01:30 AM
DSC_0040.JPG.xmp (3.46 KB) DSC_0040.JPG.xmp Matthew Halbert, 01/15/2013 01:34 AM

History

#1 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

I don't understand what you are saying. What do you mean with "Originally all metadata [...] is visible" when the image isn't exported yet? Do you mean that you can see the metadata of the original image but not of the exported one?

#2 Updated by Matthew Halbert over 7 years ago

The metadata is visible via Gnome Image Viewer before processing by darktable, but not after.
The metadata is visible in Exiftool before and after processing by darktable.

I'm wondering if darktable isn't saving the metadata exactly as it should be before blaming Gnome Image Viewer and filing the report there.

#3 Updated by Tobias Ellinghaus over 7 years ago

That doesn't make any sense. We never alter the images we read, so there can't be a before/after, just original/exported.

#4 Updated by Matthew Halbert over 7 years ago

The before image is fine and is never altered, nor has problems. An exported image ( *_dt.JPG ) is the one with problems.

#5 Updated by Tobias Ellinghaus over 7 years ago

  • Category changed from Darkroom to General

So what you try to say is that $IMAGEVIEWER has trouble with the meta data in images darktable writes. Could you please attach an example image to this report and maybe some error messages that the image viewer give in the terminal it is started from?

#6 Updated by Matthew Halbert over 7 years ago

Running "eog" from the terminal, the only print that I see is the following, which appears immediately after the command is issued. I don't think it is of any significance.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

I found an error in my previous statement I would like to retract. In darktable, saving the attached image as a JPG preserves the metadata. HOWEVER, saving as a 16 bit PNG file causes the fields to be blank as the attached photos show. Please note that the darktable image is 28 MB and therefore can be had at the following link (it may be faster to just generate your own?): http://ubuntuone.com/2aM2Kxq2hXafrE0N0j3McE

#8 Updated by Dennis Gnad over 7 years ago

"The PNG specification does not include a standard for embedded Exif image data from sources such as digital cameras. TIFF, JPEG 2000, and DNG support EXIF data." [ http://en.wikipedia.org/wiki/Portable_Network_Graphics#Comparison_to_JPEG ]

However certain software seems to still write exif into PNGs, probably using some pseudo/non-standard way, which at least exiv2 seems to support and is used by other software like that ( http://www.digikam.org/node/361 ).

It seems, this might rather be a feature request then, and not a bug?

#9 Updated by Tobias Ellinghaus over 6 years ago

  • System set to all
  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

darktable tries to write EXIF information to PNG files. There is only so much we can do about the issue as it's not even officially supported. Maybe your image viewer doesn't know how to extract the metadata from PNGs.

Also available in: Atom PDF

Go to top