Project

General

Profile

Bug #9142

export shouldn't compress history stack

Added by Antoine Beaupré over 6 years ago.

Status:
Closed: invalid
Priority:
Medium
Assignee:
-
Category:
Lighttable
Start date:
12/16/2012
Due date:
% Done:

0%

Affected Version:
1.1.0
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

As I described in #8498, I got bit by a really weird issue where the history stack gets compressed when an image is exported. To reproduce:

  1. select a previous version in the history
  2. head to the light table
  3. export the file
  • What I expected: the history should stay the same
  • What actually happend: the remaining history was trashed.

I open a separate issue from #8498 because I think this could be fixed without implementing full undo support...

Other related issues (which I can't add directly into redmine, too bad: #9019, #8769).

History

#1 Updated by Johannes Hanika over 6 years ago

  • Priority changed from High to Medium
  • Status changed from New to Closed: invalid

the history stack is your undo stack (same as undo history in gimp for example).

if you select an older version and go back to lt mode, that's what being stored to xmp and the database. what you describe has nothing to do with export and is intended behaviour.

what you probably want to support this kind of workflow is an advanced snapshot feature that will store undo trees (or at least all the tips of the branches you will cut off when you go back in the linear undo history and then exit dr or push other things on top). or simply an additoinal valid count in db that discards all elements on top of that while processing, but still loads them (maybe henrik was thinking something similar to that).

but that's not a bug report but a feature request (as #8620 should have been), certainly no 2nd issue though.

#2 Updated by Antoine Beaupré over 6 years ago

I still believe it's kind of harsh of darktable to just trash my history because i flipped between views, I wouldn't expect this to be destructive and there's certainly nothing in the UI that hints at that.

Also available in: Atom PDF