Project

General

Profile

Bug #9058

Warn before overwriting files on import

Added by Daryll Strauss over 6 years ago. Updated almost 6 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
11/19/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm doing a photo shoot today. I shot a batch of pictures, and imported them using DarkTable to a given project.
I then shot another batch of photos and imported them to DarkTable with the same project name.

Because I was using the $(SEQUENCE) as the unique portion of my file name, it wrote over the images from the first batch.

I'd argue that's a bug. It should have warned me that the files existed before overwriting them.

Luckily I had already made a backup copy, so I didn't lose my originals.

History

#1 Updated by Daryll Strauss over 6 years ago

Fedora Linux version.

#2 Updated by Ulrich Pegelow over 6 years ago

Thanks for reporting. Could you please check if this is still the case for our current development version (1.1rc2)?

#3 Updated by Simon Spannagel over 6 years ago

  • System set to Fedora/RHEL
  • % Done changed from 0 to 20
  • Target version set to Candidate for next minor release
  • Status changed from New to Incomplete

#4 Updated by Tobias Ellinghaus almost 6 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

No reaction for 8 months, closing. Btw, this is why we removed the import-from-camera code initially. :/

#5 Updated by Christian iuga almost 6 years ago

Hi,

I'm not sure understanding why we close this bug. i think we need to reopen it
We can still import picture & darktable don't verify if the file name is not already exist...

For me, darktable should warm the user OR (better) don't overwrite existing file (this test is done on the export module)

#6 Updated by Tobias Ellinghaus almost 6 years ago

  • System changed from Fedora/RHEL to all
  • Affected Version changed from 1.0.5 to git development version
  • % Done changed from 0 to 20
  • Target version deleted (Candidate for next minor release)
  • Priority changed from High to Medium
  • Status changed from Closed: invalid to Triaged

Bugs that don't get a reaction to questions get closed after some months. I am reopening. Does it still happen?

#7 Updated by Christian iuga almost 6 years ago

  • % Done changed from 20 to 100
  • Status changed from Triaged to Fixed

Hi,
Just tested now,
Sorry for the "noise", now a test is done & we can't anymore replace a existing file during the import

So the issue is fixed

Also available in: Atom PDF

Go to top