Project

General

Profile

Bug #9050

Crop and Rotate activation confusing

Added by Josef Wells over 6 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Start date:
11/15/2012
Due date:
% Done:

0%

Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I built from git on Nov 13th, so perhaps this is passing behavior, but I see:

Old behavior (1.0.5)
Activate Crop and Rotate
Mouse over picture edges to see crop bars, right click/drag to draw rotation line.

New behavior (1.1rc1+git) I can dig up the precise commit if necessary
Activate Crop and Rotate
Nothing on mouse over, clicking/right click/drag has no effect.
Collapse/Uncollapse Crop and Rotate
Mouse over/clicks/etc work as expected.

Is this a bug, by design, or am I missing an easier way to do this?

History

#1 Updated by Pascal de Bruijn over 6 years ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Sounds like a bug... We've just released Darktable 1.1~rc2, with which I cannot reproduce the problem.

Could you try 1.1~rc2 on your end and see if the problem persist?

#2 Updated by Josef Wells over 6 years ago

I pulled and rebuilt... 1.1rc2+9~g920bc8d

I still see the problem.. Same with and without fullscreen.

Are there related debug messages I could turn on or add?

#3 Updated by Josef Wells over 6 years ago

I pulled the 1.0.5 tag and did a build/install. That version as built by me does still work, so it is probably not my build environment either.

I'll just do a manual bisect...

#4 Updated by Josef Wells over 6 years ago

Doing the bisect the problem seems to change over time, hard to say exactly how, since bisect bounces you around so much.

In some versions, turning on a plugin also expands it. This tends to work with the Crop/Rotate plugin.

In versions where turning on a plugin doesn't expand it, sometimes it still works because it gives that plugin focus somehow, which makes the mouse work on the picture for Crop/Rotate.

Try this:
Expand Crop/Rotate as well as another plugin.
Click the other plugins option area, it should highlight.
Now go back and turn on Crop/Rotate... it doesn't get focus and the mouse doesn't work on the picture.

Bisect takes me here:
294103ca4e6cf32e2df0cd3e5461e4824e3c43b0
remove the auto-expanding feature fixes Issue #8644

#5 Updated by Ulrich Pegelow over 6 years ago

Admittedly I don't see an issue at all currently. Maybe I misunderstand your point.

For me gui behavior of crop/rotate looks consistent. Mouse-over controls appear as long as
the module is in focus. In order for the module to get focus it needs to be expanded and
highlighted (mouse click).

Merely activating a module does not put it in focus. This is reasonable, because you might
be interested to quickly see the effect with/without module A while optimizing parameters
on module B. It would be tedious if darktable would always put focus on module A, just
because you activated it.

#6 Updated by Josef Wells over 6 years ago

After reading Issue #8644 I see my expectations were off.

I was using the on/off button to activate and change the rotate/crop settings. I need to just click the title to open the controls in order to activate it.. then, making changes on the picture automatically turns it on.

The only odd part is that if crop/rotate is already expanded, and you click it the on/off to toggle it on, the mouse doesn't react over the picture. You need to then click on the modules itself to give it focus.

I think it is inline with issue 8644 to also give a module focus (regardless of it being collapsed/expanded) when it is turned on.

Make sense?

#7 Updated by Ulrich Pegelow over 6 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Duplicate
  • Priority changed from High to Low

So people have different preferences for that behavior. In that sense it's already covered in #8644.

Closed here.

Also available in: Atom PDF