Project

General

Profile

Bug #9047

No EXIF data for images on read-only filesystem

Added by Claudio Dalla Vecchia over 6 years ago. Updated over 5 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Start date:
11/11/2012
Due date:
% Done:

0%

Affected Version:
1.0.5
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Bug:

- Darktable cannot read RAW images EXIF data from pictures on a read-only filesystem (external HD); the info panel shows only the image size.

System:

- Ubuntu 12.10 Quantal on iMac
- External HD (containing the pictures) formatted Apple HFS+ and mounted read-only

Software:

- Darktable v1.0.5
- Darktable v 1.1~rc1

Files type:

- Nikon NEF

Extra info:

- I share pictures between OS X and Linux with an external HD formatted HFS+ and I can't read RAW images properly. The image is read in correctly, but the EXIF data is missing.
- Other software (e.g. Photivo, Ufraw, which are not my first choices) reads EXIF data correctly.
- Enabling/disabling writing sidecar files does not change Darktable behaviour.
- The bug is present in v1.0.5 as well as in v1.1~rc1 (I am actually using the latter, but I did a downgrade to v1.0.5 to check that the bug was there too).

History

#1 Updated by Johannes Hanika over 6 years ago

you sure ro is the issue and not an exiv2 version on your mac installation?

#2 Updated by Claudio Dalla Vecchia over 6 years ago

Hi Johannes,

It wasn't related to the exiv2 version (I use Ubuntu 12.10 Quantal which is quite up to date). I wasn't either an issue with RO filesystem, since after some more testing only one folder was giving problems with EXIF data.

After some discussion on the IRC channel, I was suggested to clear the cache and use a temporary DB file. That didn't solve the problem, but renaming the folder did (the original name was however fine). I think something was messed up in the DB, or the original import went wrong. I tried to reproduce the problem, but haven't been lucky. Therefore, I would suggest to close this ticket for now, unless you have more questions. I'll keep an eye on darkrtable log and let you know if it happens again (possibly with more details).

#3 Updated by Tobias Ellinghaus over 5 years ago

  • bitness set to 64-bit
  • System set to Ubuntu
  • Status changed from New to Closed: invalid

Also available in: Atom PDF