Project

General

Profile

Bug #9034

watermark missing fonts on OSX crashes release 1.1rc1

Added by Guilherme Brondani Torri over 7 years ago. Updated over 6 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Start date:
11/04/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello, I am running the packaged darktable for 1.1rc1 on OSX 10.6.8 (Snow Leopard).

To reproduce: include the watermark darktable.svg into an image, and try to zoom in.

The characters are replaced by squares, and soon after you try to zoom darktable crashes.

The Apple Crash Report mentions something like:

...
Thread 0:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib                 0x00007fff89afad7a mach_msg_trap + 10
1   libSystem.B.dylib                 0x00007fff89afb3ed mach_msg + 59
2   com.apple.CoreGraphics            0x00007fff84a23230 _CGSSynchronizeWindowBackingStore + 97
3   com.apple.CoreGraphics            0x00007fff84a08da9 _CGSLockWindow + 4515
4   com.apple.CoreGraphics            0x00007fff84a0f93f CGSDeviceLock + 535
5   libRIP.A.dylib                    0x00007fff88fd7e7b ripd_Lock + 46
6   libRIP.A.dylib                    0x00007fff88fd7781 ripl_BltShape + 410
7   libRIP.A.dylib                    0x00007fff88fd4dd2 ripc_Render + 375
8   libRIP.A.dylib                    0x00007fff88fd2367 ripc_DrawRects + 732
9   com.apple.CoreGraphics            0x00007fff84a0f281 CGContextFillRects + 143
10  com.apple.CoreGraphics            0x00007fff84a45a4a CGContextFillRect + 18
11  libgdk-quartz-2.0.0.dylib         0x000000010045f08a gdk_window_impl_quartz_begin_paint_region + 378
12  libgdk-quartz-2.0.0.dylib         0x000000010043fbb3 gdk_window_begin_paint_region + 323
13  libgtk-quartz-2.0.0.dylib         0x00000001005951a8 gtk_main_do_event + 1000
14  libgdk-quartz-2.0.0.dylib         0x0000000100440c2d _gdk_window_process_updates_recurse + 493
15  libgdk-quartz-2.0.0.dylib         0x0000000100440b74 _gdk_window_process_updates_recurse + 308
16  libgdk-quartz-2.0.0.dylib         0x000000010044cd1d -[GdkQuartzView drawRect:] + 333
17  com.apple.AppKit                  0x00007fff89e4acc5 -[NSView _drawRect:clip:] + 3390
...

On a version I compiled myself, running from the terminal it gives the following messages before crashing:

(darktable:55299): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed

(darktable:55299): GLib-GObject-CRITICAL **: g_object_get_qdata: assertion `G_IS_OBJECT (object)' failed

(darktable:55299): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion `G_IS_OBJECT (object)' failed

(darktable:55299): Pango-CRITICAL **: pango_fontset_foreach: assertion `PANGO_IS_FONTSET (fontset)' failed

(darktable:55299): Pango-CRITICAL **: pango_fontset_foreach: assertion `PANGO_IS_FONTSET (fontset)' failed

(darktable:55299): Pango-CRITICAL **: pango_fontset_foreach: assertion `PANGO_IS_FONTSET (fontset)' failed

(darktable:55299): Pango-CRITICAL **: pango_fontset_foreach: assertion `PANGO_IS_FONTSET (fontset)' failed

(darktable:55299): Pango-CRITICAL **: pango_fontset_foreach: assertion `PANGO_IS_FONTSET (fontset)' failed

(darktable:55299): Pango-CRITICAL **: pango_fontset_foreach: assertion `PANGO_IS_FONTSET (fontset)' failed
...

Possible solutions: Change fonts on darktable.svg which are available across platforms?

Opening darktable.svg into Inkscape it hints that the fonts FreeSans and AlMateen are not found in my system. Say I change these fonts to Arial and save with another name, this new watermark doesn't crash darktable.

Screen shot 2012-11-04 at 17.09.55.png (76.3 KB) Screen shot 2012-11-04 at 17.09.55.png Missing font? Guilherme Brondani Torri, 11/04/2012 04:21 PM
watermark_crash_osx.txt (79.1 KB) watermark_crash_osx.txt full crash report Guilherme Brondani Torri, 11/04/2012 04:21 PM

History

#1 Updated by Guilherme Brondani Torri over 7 years ago

  • Target version changed from Candidate for next major release to Candidate for next minor release

#2 Updated by Igor Kuzmin over 7 years ago

  • % Done changed from 0 to 10
  • Status changed from New to Confirmed

Are all characters displayed as squares for you? Because on my mac it's only the last line.
Also, when looking for relevant backtrace, you should find thread marked "crashed", it's not always the first one in crash log.

#3 Updated by Guilherme Brondani Torri over 7 years ago

Indeed, it is only the second line that turns into squares (see screenshot).

Here is the crashed thread:

Thread 9 Crashed:
0   libglib-2.0.0.dylib               0x00000001002d1ecd g_logv + 749
1   libglib-2.0.0.dylib               0x00000001002d1fe4 g_log + 116
2   libpangocairo-1.0.0.dylib         0x0000000100ecacb1 pango_core_text_font_map_load_fontset + 401
3   libpango-1.0.0.dylib              0x0000000100a250a5 itemize_state_process_run + 501
4   libpango-1.0.0.dylib              0x0000000100a24b58 pango_itemize_with_base_dir + 216
5   libpango-1.0.0.dylib              0x0000000100a2a868 pango_layout_check_lines + 696
6   libpango-1.0.0.dylib              0x0000000100a2ecdb pango_layout_get_extents_internal + 235
7   libpango-1.0.0.dylib              0x0000000100a2f31f pango_layout_get_size + 63
8   librsvg-2.2.dylib                 0x0000000100efd08d _rsvg_node_text_type_children + 221
9   librsvg-2.2.dylib                 0x0000000100efd3b7 _rsvg_node_text_type_children + 1031
10  librsvg-2.2.dylib                 0x0000000100efc949 _rsvg_node_text_draw + 457
11  librsvg-2.2.dylib                 0x0000000100ef67a6 rsvg_node_draw + 102
12  librsvg-2.2.dylib                 0x0000000100ef684f _rsvg_node_draw_children + 95
13  librsvg-2.2.dylib                 0x0000000100ef67a6 rsvg_node_draw + 102
14  librsvg-2.2.dylib                 0x0000000100ef702f rsvg_node_svg_draw + 911
15  librsvg-2.2.dylib                 0x0000000100ef67a6 rsvg_node_draw + 102
16  librsvg-2.2.dylib                 0x0000000100f042eb rsvg_handle_render_cairo_sub + 219
17  libwatermark.so                   0x0000000154a2506a process + 970 (watermark.c:626)
18  ???                               0x3ff0000000000000 0 + 4607182418800017408

Full backtrace also attached.

#4 Updated by Tobias Ellinghaus over 6 years ago

  • System set to Mac OS X
  • % Done changed from 10 to 20
  • Status changed from Confirmed to Incomplete

Did this get fixed in the meantime?

#5 Updated by Tobias Ellinghaus over 6 years ago

  • bitness set to 64-bit
  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

Closing here. Feel free to reopen.

Also available in: Atom PDF

Go to top