Project

General

Profile

Bug #9026

Crash when Deleting From Disk

Added by Rick Gabriel about 7 years ago. Updated over 4 years ago.

Status:
Closed: invalid
Priority:
Critical
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
10/28/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
unknown
bitness:
hardware architecture:
amd64/x86

Description

When deleting files from disk in Lightroom mode, the application often crashes with the most recent daily version. It's very frequent, but perhaps more common when lots of files are selected? When this happens, the files are indeed removed from the Darktable database, but they are not deleted from the disk.

I am running Linux Mint 13. The files are stored on an SSD with ext4. This issue did not happen with the version from last week.

Darktable Delete Crash.txt (13.2 KB) Darktable Delete Crash.txt Backtrace Rick Gabriel, 12/16/2012 09:57 PM

History

#1 Updated by Rick Gabriel about 7 years ago

This also seems more likely to happen when using the keyboard Delete key instead of the Delete button. I'm still trying to identify a definite pattern.

#2 Updated by Ulrich Pegelow about 7 years ago

Any confirmation if this still happens?

#3 Updated by Rick Gabriel about 7 years ago

I'm not sure if it is still a problem since I haven't been deleting much lately. However, the latest daily versions of darktable do seem more prone to crashing than those from a while ago. Sometimes just switching tabs or activating a module will produce a crash, but it doesn't appear consistent. I'll run darktable from within a shell to try to capture some useful data if it crashes again.

#4 Updated by Rick Gabriel about 7 years ago

  • % Done changed from 0 to 10
  • Status changed from New to Confirmed

This is actually still a problem. It happens intermittently and I haven't pinpointed absolute reproduction steps yet, but it is frequent.

#5 Updated by Florent Thiery about 7 years ago

Also experienced it on Archlinux / darktable 1.1. Doesn't happen every time though.

#6 Updated by Rick Gabriel about 7 years ago

I got this when running from the command line on a failed delete:

  • glibc detected * darktable: realloc(): invalid next size: 0x00007f3bb00068a0 *
  • glibc detected * darktable: malloc(): memory corruption: 0x0000000003b24250 *

#7 Updated by Rick Gabriel about 7 years ago

Here's more information and a backtrace. I really wish this could be fixed because it's very frustrating trying to work with and delete photos with Darktable crashing all the time.

#8 Updated by Rick Gabriel about 7 years ago

Almost another month has gone by and this bug still exists. About 50% of the time, when I delete from disk using Lighttable, Darktable crashes. The images are removed from the Darktable database, but they are not deleted from disk. Then I have to go through each one by one and manually delete using other means. This affects Darktable 1.1 stable as well. How can this not be a high priority bug? What more information can I provide to get this fixed? Thanks.

#9 Updated by Jose Carlos Garcia Sogo almost 7 years ago

  • System set to unknown

While I think the bug is valid, the backtrace you are providing is not useful, because it lacks the proper information. You should follow this instructions for providing one http://www.darktable.org/development/#backtrace

If you can reproduce it, please try to do that in the appropiate conditions so you can provide us the needed information.

Thanks

#10 Updated by Rick Gabriel almost 7 years ago

This problem has not happened in a while and may be fixed. It's too bad that it existed for so long and that it took over 4 months to acknowledge such an important problem and to ask for more information. You can probably close this report now and I'll reopen if it happens again.

#11 Updated by Jose Carlos Garcia Sogo almost 7 years ago

  • % Done changed from 10 to 0
  • Status changed from Confirmed to Closed: invalid

Rick Gabriel wrote:

This problem has not happened in a while and may be fixed. It's too bad that it existed for so long and that it took over 4 months to acknowledge such an important problem and to ask for more information. You can probably close this report now and I'll reopen if it happens again.

Our fault. Please feel free to reopen this bug if it happens again to you.

Thanks for your patience.

#12 Updated by Freddie Chopin over 4 years ago

I'm seeing the same behavior repeatedly - it started happening recently (maybe month ago, so in current version). When I delete a file Darktable crashes after 1-10 deletions. The file (.NEF) stays on disk but is removed from the collection. This happens with a stable 1.6.8 version from Arch Linux repositories.

Also available in: Atom PDF

Go to top