Project

General

Profile

Bug #9002

Exporting after rotating image 90' results in corrupted output

Added by Daniel Blueman over 7 years ago.

Status:
Closed: won't fix
Priority:
Medium
Assignee:
-
Category:
Darkroom
Start date:
10/16/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
1.0.5
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Steps to consistently reproduce:
1. import raw file
2. rotate +90'
3. export as eg PNG
4. observe image corruption

I'll attach example raw and output images. Environment is stock Ubuntu 12.10 x86-64 with stable Darkable 1.0.5 PPA.

Note, if I rotate the image eg 89.5' or 90.5', the corruption does not occur.

History

#1 Updated by Daniel Blueman over 7 years ago

Example raw file to rotate 90' and export:
http://quora.org/2012/darktable/20121014-175946.nef

Example output when I rotate it 90':
http://quora.org/2012/darktable/20121014-175946.png

#2 Updated by Ulrich Pegelow over 7 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

I can not confirm here with git master. All exports with 90° work fine, regardless of the export format.

Could you please recheck with a recent development version. Chances are that we have fixed the bug already in our
development branch (we won't do further fixes for 1.0.5 but only for the upcoming 1.1).

#3 Updated by Daniel Blueman over 7 years ago

Thanks for getting back to me, Ulrich, and sorry for the delayed response!

I can't reproduce the issue with the development version, built a week ago in Pascal's PPA (1:1.0+2031~g59c77f7-0pmjdebruijn1~precise), but can of course with 1.0.5.

#4 Updated by Ulrich Pegelow over 7 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: won't fix

Thanks for your feedback.

As written before, we won't release further bugfixes in our 1.0 branch. So you need to hold your breath until
version 1.1 comes out, which should not be too long from now.

Also available in: Atom PDF

Go to top