Project

General

Profile

Feature #8938

Output Sharpening / Styles

Added by Rick Gabriel over 6 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
General
Target version:
-
Start date:
09/23/2012
Due date:
% Done:

0%

Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Add the ability to apply sharpening and styles/presets on processed images during export. This is useful when you are outputting the same images several times for different targets. Other software like Lightroom and AfterShot pro have this functionality.

Example: the final images are scaled down for use on the web. Additional sharpening with a radius of 0.3px is needed to compensate for softness after scaling.

Example: Add watermark after output when targeting web but not print.

Example: Add a second level of sharpening after the images are processed and exported depending on the target print size.

Aftershot Export Dialog.png (47.5 KB) Rick Gabriel, 09/23/2012 03:00 AM


Related issues

Related to darktable - Feature #8777: Styles in Export options Fixed 06/13/2012

History

#1 Updated by Rick Gabriel over 6 years ago

This appears to be a natural extension of bug #8777 and a feature to apply styles upon export after processing would solve both issues.

#2 Updated by Rick Gabriel over 6 years ago

Aftershot lets the user select any style to apply during the export process and then they have a special section for output sharpening that takes place on the final processed image as a last step. The settings and XMP are not affected by these temporary export styles. It works great for outputting to multiple targets. See attached screenshot.

#3 Updated by Simon Spannagel over 6 years ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Usually things like this are addressed in darktable using duplicates of an image. Just click the "duplicate" button in lightroom and you get the image twice. You can apply your styles to all these duplicates.
For a better overview, all duplicates are grouped with the original and you are able to collapse them to one image again (this feature is only in git master development version yet)

Doesn't that suit your workflow?

#4 Updated by Rick Gabriel over 6 years ago

Thanks for the workaround idea, but that doesn't quite solve the issue. As you can see from the couple similar tickets about this, users often export the same image several times for multiple targets (web, small print, large print, etc.). We need to apply extra sharpening on the final result after all other processing. In effect, there are three phases of sharpening and from what I can tell DT only supports one. Check out this article. I'm sure you already know most of it, but it's a good read and may explain why the duplicating option isn't workable.
http://www.cambridgeincolour.com/tutorials/image-sharpening.htm

Aside from output sharpening, it's desirable to apply styles during normal processing but just for a single output/target. For example, I add a copyright watermark to web images but not large prints. You already have resizing in the export module. I suggest adding an option for output sharpening and a way to add styles to the pipeline from there as well. ASP, LR, and others have this functionality for a good reason. Thanks!

#5 Updated by Tobias Ellinghaus over 6 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Duplicate

I am closing this one since it's now a duplicate of ticket #8777.

Also available in: Atom PDF