Project

General

Profile

Bug #8916

Import Problem : Import only first with specifi filename structure

Added by Christian iuga almost 7 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
09/08/2012
Due date:
% Done:

0%

Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,
WIth my configuration of darktable, actually it's only import one picture :

Import Option :

directory structure : $(EXIF_YEAR) $(EXIF_MONTH) $(EXIF_DAY) - $(JOBCODE)
filename structure : $(EXIF_YEAR)-$(EXIF_MONTH)-$(EXIF_DAY)--$(EXIF_HOUR).$(EXIF_MINUTE).$(EXIF_SECOND).$(FILE_EXTENSION)

usualy, i'm not using the VAR _$(SEQUENCE) as i'm always take photo with more interval than one second.
or Dt should be able to detect file already exist (as it's done when exporting & rename it automaticaly _2)

tested version : 1.0.5 & git of 28 august.

We have 2 bug on it :

1) Actually dartable is not able to read this information ( $(EXIF_YEAR)-$(EXIF_MONTH)-$(EXIF_DAY)--$(EXIF_HOUR).$(EXIF_MINUTE).$(EXIF_SECOND) ) when importing (but it's work well when exporting !...)
These var are replaced by the correspond var of `date --date "now"`

2) Dt is not testing the destination file is already exist & will delete orignal file (if option select) without a test if correctly downloaded (i have lost some picture but recover them with photorec of the package testdisk)

Darktable say importing 41 pictures,
importing 1 per 41
importing 2 per 41
...
importing 41 per 41

Then i'm looking on what it's imported (with darktable or nautilus ) : only one picture, the first imported.


Related issues

Related to darktable - Feature #8415: camera import: using Exif-date Fixed

History

#1 Updated by Tobias Ellinghaus almost 7 years ago

  • Status changed from New to Duplicate

This is basically a duplicate of #8415. The overwriting is mentioned in some other report, too. IIRC.

Also available in: Atom PDF