Project

General

Profile

Bug #8898

DT crash when trying to filter by tag (if broken tags are present)

Added by Emmanuel Lacour almost 7 years ago. Updated over 5 years ago.

Status:
Closed: invalid
Priority:
Low
Category:
Lighttable
Start date:
08/31/2012
Due date:
% Done:

0%

Affected Version:
git development version
System:
unknown
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I just imported a lot of old pictures from my HD, then closed DT, then openned it again, on the "collection filter" in lighttable I selected "tag" instead of "folders", DT crashed.

Output from -d ALL:

[sql] prepare "select distinct name, id from tags where name like '%%'"
backtrace written to /tmp/darktable_bt_ZDK6JW.txt

I join the BT file.

darktable_bt_ZDK6JW.txt Magnifier - Backtrace (21.4 KB) Emmanuel Lacour, 08/31/2012 02:34 PM

History

#1 Updated by Tobias Ellinghaus over 6 years ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Could you please try this with a more recent version? Best would be a compile from git master (depending on your distribution there might be prepackaged versions).

#2 Updated by Emmanuel Lacour over 6 years ago

I just built master and tested, same problem appear.

#3 Updated by Jose Carlos Garcia Sogo over 6 years ago

  • Affected Version changed from 1.0.4 to git development version
  • Assignee set to Jose Carlos Garcia Sogo
  • Target version set to Candidate for next major release
I think we will need more info. I can't reproduce it.
  • Which kind of images were those?
  • Did they have tabs applied?
  • Can we get an example?

#4 Updated by Mikko Ruohola over 6 years ago

Well, I got this one too now. Maybe it needs certain kind of tag in database?

#5 Updated by Mikko Ruohola over 6 years ago

Fixed it by removing 2 offending tags, which I don't now have, as I removed them. they showed funny characters in the list, so I think there has been some encoding issues in one of my previous darktable builds(from 0.4* series to current...a hundred builds?)
Maybe you need to fabricate a broken tag in to the database or some xmp file to get this fixed..

#6 Updated by Jose Carlos Garcia Sogo over 6 years ago

  • Subject changed from DT crash when trying to filter by tag to DT crash when trying to filter by tag (if broken tags are present)

#7 Updated by Tobias Ellinghaus over 5 years ago

  • System set to unknown

Can anyone supply an example that crashes darktable? Or tell us if it's no longer crashing?

#8 Updated by Tobias Ellinghaus over 5 years ago

  • Status changed from Incomplete to Closed: invalid
  • % Done changed from 20 to 0
  • bitness set to 64-bit

Noone? Well, I am closing here. Feel free to reopen once a tag/XMP file that triggers a crash can be found.

#9 Updated by Emmanuel Lacour over 5 years ago

Hi and sorry for the late response. I no longer have this problem. I think it was caused by a multiline tag with maybe specific chars imported from old pictures (processed by xview ...). I cleaned thos tag months ago and problem is gone but unfortunatly I cannot say it was the root cause. I agree to close this bug.

Also available in: Atom PDF