Project

General

Profile

Bug #8863

Bug #8480: Import from Camera Overwrites Images

Importing from camera with "delete originals after import" into existing filmroll name overwrites existing images

Added by Peter Boström over 7 years ago.

Status:
Fixed
Priority:
Low
Category:
-
Start date:
08/16/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

(Affected version: 1.0.5, Ubuntu 12.04)

When importing into an existing filmroll, images either don't get imported, or get overwritten. When deleting originals, existing images are overwritten.

Steps to reproduce:

(Using Mass Storage Camera)

  1. Take a few unimportant pictures.
  2. Import from camera (msd camera)
  3. Under "settings", enable "delete originals after import"
  4. Back under images, select a few of the unimportant pictures. Name the filmroll "foo", and press "import".
  5. Import from camera again, select a few others of the imported pictures. Name this filmroll "foo" as well, so it imports to the same filmroll/folder. Press import.

Existing thumbnails stay as they are, but when you open the first picture, it's the first of the newly imported ones, the old first one seem gone.

Suggested solution:

Dialog: "Filmroll exists, import into existing filmroll 'foo'?" and import with higher numbers.

History

#1 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Triaged

I am 100% sure that we have this already in some bug report. But just in case I am mistaken I leave this open ...

#2 Updated by Henrik Andersson over 7 years ago

  • Parent task set to #8480
  • % Done changed from 20 to 100
  • Target version set to Candidate for next minor release
  • Assignee set to Henrik Andersson
  • Status changed from Triaged to Fixed

This has been fixed in parent issue #8480.

Also available in: Atom PDF

Go to top