Project

General

Profile

Bug #8856

Filmroll search by partial string/with wildcard is broken

Added by Markus Jung over 7 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
-
Category:
Lighttable
Start date:
08/11/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Affected version: 1.0.5 (not available in dropdown list)

Searching for filmrolls using the "collect" module in lighttable shows only images matching the full path name. Therefore, it is not possible to search for a specific word/substring (example: 2012) in the filmroll name without adding % manually around the search clause.
This behaviour is misleading because if the filmroll is shown as "some-filmroll-name" in the list, i would expect "some" to match the filmroll, or at least "some%". But only "%some%" works, but a normal user can not see any reason why a wildcard in front of the clause should be required.

The reason is quite simple: The search clause is matched against the whole path string, therefore the wildcard is required. However, like noted above, this conflicts with the way the user interacts with the input mask. Other filters (i tried timestamp) wrap the search clause in "%" for this reason. Maybe this should be done for the filmroll filter, too? (And of course for other filters, if applicable)

History

#1 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 0 to 100
  • Target version set to Candidate for next minor release
  • Status changed from New to Fixed

Also available in: Atom PDF

Go to top