Project

General

Profile

Bug #8855

Exporting images to jpg sometimes fails when using equalizer (dt 1.0.5)

Added by Remco Jansen about 5 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
08/09/2012
Due date:
% Done:

0%

Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Exporting images to jpg fails regularly when using the equalizer plug. After disabling I am able to export to jpg. Failing images get "rendered" partly or not at all, as can be seen here:

RAW File info (can't upload, file too large):
File Name: IMG_1096.CR2
Camera Make: Canon
Camera Model: Canon EOS 450D
Date/Time: 2012:08:04 08:28:37
Resolution: 4290 x 2856
Flash Used: No
Focal Length: 55.0mm (35mm equivalent: 89mm...
CCD Width: 22.30mm
Exposure Time: 0.0100 s (1/100)
Aperture: f/13.0
ISO Equiv.: 200
Whitebalance: Auto
Metering Mode: pattern
Exposure: aperture priority (semi-auto)

Darktable plugins used (as shown in history):
9. equalizer (on)
8. velvia (on)
7. overexposed (off)
6. sharpen (on)
5. tone curve (on)
4. lens correction (on)
3. chromatic aberrations (on)
2. exposure (on)
1. white balance (on)

IMG_1096.CR2.xmp - Sidecar file for problem image (6.41 KB) Remco Jansen, 08/09/2012 07:24 PM

History

#1 Updated by Tobias Ellinghaus about 5 years ago

This looks as if darktable ran out of memory while exporting. Do you use a 32bit system? How much main memory does your computer have? You can try to decrease the memory size in the preferences (and restart darktable).

#2 Updated by Remco Jansen about 5 years ago

It is a 32 bit system, with 4GB of memory. I'll try your suggustion and report back here.

#3 Updated by Remco Jansen about 5 years ago

After limiting the host memory for tiling down to 1024 (from the default 1500) the exports worked ok. Thank for the tip. An errormessage about running out of memory would be nice though... but i'm sure that'll happen sometime in the future

#4 Updated by Simon Spannagel about 5 years ago

  • Status changed from New to Closed: invalid

closing this as "invalid", not a bug.
A message would be nice, indeed...

Also available in: Atom PDF