Project

General

Profile

Bug #8828

black squares in exported image

Added by neimo källi over 7 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
-
Category:
Darkroom
Start date:
07/19/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.0.4
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Exported image has huge black squares on it, covering up to a third of the entire image area.

Running in ubuntu precise, darktable installed from ubuntu software center. For some reason I couldn't attach the problem file, will try to host elsewhere.

DSC05700.ARW.xmp (5.77 KB) DSC05700.ARW.xmp neimo källi, 07/19/2012 02:17 PM

Associated revisions

Revision fc8998b9 (diff)
Added by Ulrich Pegelow about 7 years ago

fix for bug #8828 (black squares in exported images)

Issue was caused by a division by zero in module "input color profile"
subsequently leading to problems of module "equalizer" with the resulting NaN's

History

#1 Updated by Simon Spannagel over 7 years ago

  • % Done changed from 0 to 20
  • Priority changed from High to Medium
  • Status changed from New to Incomplete

Dear Neimo,

beside the exported file we would need some more information and data:

  • which camera is the image from? (Maybe host the raw file somewhere)
  • which modules did you enable? (Attach xmp file)
  • Do you use OpenCL? (Attach your ~/.config/darktable/darktablerc)
  • Did this happen with other images from the same camera?

Besdie that: are you really using darktable 0.9.3 in precise? That version is really outdated and is not supported anymore. I strongly recommend updating using our PPA. For more information see here: http://www.darktable.org/install#ubuntu

Simon

#2 Updated by neimo källi over 7 years ago

Simon Spannagel wrote:

Dear Neimo,

beside the exported file we would need some more information and data:

  • which camera is the image from? (Maybe host the raw file somewhere)
  • which modules did you enable? (Attach xmp file)
  • Do you use OpenCL? (Attach your ~/.config/darktable/darktablerc)
  • Did this happen with other images from the same camera?

Besdie that: are you really using darktable 0.9.3 in precise? That version is really outdated and is not supported anymore. I strongly recommend updating using our PPA. For more information see here: http://www.darktable.org/install#ubuntu

Simon

I will upload the files when I get back home later today. I have seen this in only one image, I just started using the program and have exported maybe 3 image files total. All images from sony dslr A200.

I installed directly from software center/default repositories, 0.9.3 is what it says. I'll try a newer version to see if the problem goes away.

#3 Updated by Simon Spannagel over 7 years ago

As said, please update to 1.0.4 by using our PPA (If you don't know what this is, google it...) as 0.9.3 is not longer maintained.
In 1.0.4 so many things got updated and changed so it's quite likely that your problem is already fixed.

#4 Updated by Simon Spannagel over 7 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

Feel free to re-open if you still face problems with the latest stable version.

#5 Updated by neimo källi over 7 years ago

Unfortunately the problem persists in 1.0.4. I didn't touch any settings after installing, just opened that one file and then exported. I will try to get the files online shortly.

#7 Updated by neimo källi over 7 years ago

and I can't figure out how to reopen this. I guess I wouldn't have the privileges needed.

#8 Updated by Simon Spannagel over 7 years ago

  • Affected Version changed from 0.9.3 to 1.0.4
  • % Done changed from 0 to 20
  • Status changed from Closed: invalid to Triaged

reopened and confirmed, same for me with your XMP and current git master (as of e68afd).

Set to "triaged".

History stack contains:
  • equalizer
  • lowlight vision
  • white balance
  • sharpen

Camera: SONY DSLR-A200

Reproducible without OpenCL.

#9 Updated by Ulrich Pegelow about 7 years ago

The artifact can be clearly traced back to equalizer. Even with default settings black squares are produced on export. No difference between cpu and gpu codepath, so I assume it's an issue with the underlying algorithm.

As I don't have any idea why this happens for certain images I put hanatos in copy.

#10 Updated by Ulrich Pegelow about 7 years ago

Some additional observations and a speculation.

When I activate blending (blend mode normal, 100% opacity) on a module that precedes equalizer (e.g. vibrance), the artifacts are gone. Blending must be activated for this, otherwise artifacts stay. This blend setting is more or less a noop. However, it will in any case clamp the module's output.

My speculation is that the artifacts might be caused by invalid pixel values, maybe negative L values.

#11 Updated by Ulrich Pegelow about 7 years ago

Some further experiments: I tested some clamping code in equalizer applied prior to eaw_decomposition. Interestingly it's not the L channel that causes problems but the values in a and b. Clamping them to -128..128 prevents the black square artifact.

@hanatos: does this make sense to you? should we clamp equalizer input by default?

#12 Updated by Ulrich Pegelow about 7 years ago

OK, getting closer.

Seems that the cause of the problem are non-finite floats that module "input profile" is generating (run DT compiled in debug mode). Module equalizer reacts very heavily on them and produces black squares. Clamping prior to equalizer would be a solution but IMHO it would be preferable to prevent infinite floats at their origin.

Putting Pascal in copy, hoping that he has an idea why this happens here.

#13 Updated by Ulrich Pegelow about 7 years ago

  • % Done changed from 20 to 100
  • Target version set to Candidate for next major release
  • Status changed from Triaged to Fixed

So, finally there is a fix in git master. Root cause of the issue is a division by zero under certain circumstances in module "input color profile". The resulting NaN's finally cause module "equalizer" to make all those funny things.

Also available in: Atom PDF

Go to top