Project

General

Profile

Bug #8816

color labels can't be cleared/inverted in multi-image selections

Added by Markus Jung over 7 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Lighttable
Start date:
07/05/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.0.4
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Color labels can't be cleared/inverted any more if more than one image is selected.

Reproducing is quite simple:
Select more than one image, move the mouse out of the filmstrip to clear higlighting and press a color label button twice. (Or use the according shortcut)
Expected: The label gets toggled/inverted on/off.
What happens: The labels are only set, but not cleared.

This is a regression which appeared somewhere around the release of 1.0 (or maybe one of the last 0.9.x releases)


Related issues

Related to darktable - Bug #8920: shift-click selects first image twiceFixed09/09/2012

Associated revisions

Revision 829048e8 (diff)
Added by Tobias Ellinghaus over 7 years ago

Fix #8816 #8915 #8920: add selected images once to db

Range selection used to add the first image twice to the selected_images
table.

History

#1 Updated by Simon Spannagel over 7 years ago

  • % Done changed from 0 to 20
  • Target version set to Candidate for next patch release
  • Priority changed from Medium to Low
  • Status changed from New to Incomplete

Lighttable <-> Film strip?
You mean the center veiw port or really the film strip as in darkroom and tethering mode?

#2 Updated by Markus Jung over 7 years ago

Simon Spannagel wrote:

Lighttable <-> Film strip?
You mean the center veiw port or really the film strip as in darkroom and tethering mode?

I talk about the lighttable-filmstrip. Sorry if this was unclear.

#3 Updated by Richard Wonka over 7 years ago

This seems related to #8772

#4 Updated by Markus Jung over 7 years ago

Richard Wonka wrote:

This seems related to #8772

I am not sure. This is not about the active selection which gets overwritten by hovering, but about wrong applied color labels.

#5 Updated by Markus Jung over 7 years ago

  • % Done changed from 20 to 100
  • Status changed from Incomplete to Fixed

This issue appears to be fixed in darktable 1.0.5, great ;)

#6 Updated by Richard Wonka over 7 years ago

I can clear colour labels, but still only the image hovered over is affected instead of the entire selection... file new bug?

#7 Updated by Simon Spannagel over 7 years ago

maybe better, yes.
thanks.

#8 Updated by Markus Jung over 7 years ago

Richard Wonka wrote:

I can clear colour labels, but still only the image hovered over is affected instead of the entire selection... file new bug?

I don't know if the selection-override by hovering is intented, but if move your mouse away (--> no image is hovered), it works with the chosen selection, as expected.

#9 Updated by Markus Jung over 7 years ago

@Simon Spannagel: Could you set this issue back to incomplete please? I just discovered this issue is not fixed, but instead occurs only in one special case, therefore i came to the wrong conclusion.

Bug description update:
This bug only appears if the selection is a range-selection (click first image, shift-click second image). Multi-image- selections assembled by strg-click work will be broken as soon a range-selection is added. There has been a fix in 1.0.4 or maybe even 1.0.3 which made range-selections work better (they had ugly limitations before), i assume this fix introduced the observed behaviour.

#10 Updated by Simon Spannagel over 7 years ago

  • % Done changed from 100 to 20
  • Status changed from Fixed to Incomplete

Of course... :D

#11 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 20 to 100
  • Status changed from Incomplete to Fixed

Applied in changeset darktable|commit:829048e81b6289a8f2302f81788aaefcba4a9590.

Also available in: Atom PDF

Go to top