Project

General

Profile

Feature #8799

Show filename and -directory in Image Information module

Added by Richard Wonka about 7 years ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
General
Target version:
-
Start date:
06/23/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

It would be nice to have filename and -directory added to the information module.

History

#1 Updated by Simon Spannagel about 7 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Filename is already there.
Directory is your film roll. For more path depth change the config parameter "number of folder levels to be shown in list" (or similar).

You really need more information there?

#2 Updated by Richard Wonka about 7 years ago

just figured this out or IRC. - How about an option that shows the path to the image starting at $(PICTURES_FOLDER)?

#3 Updated by Simon Spannagel about 7 years ago

Afaik there is no "$(PICTURES_FOLDER) for darktable, you can add whatever sails your boat. dt does not rely on you putting all your image work in /home/user/pictures - so you would have to display the abs. path.

#4 Updated by Richard Wonka about 7 years ago

Ah, yes, I forgot about that. Is this by design or just because that's how it happened to be implemented?

#5 Updated by Simon Spannagel about 7 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: won't fix

by design. Quoting Johannes from IRC:

(14:43:03) sanso: then why is it not called a directory?
(14:43:06) hanatos: and there's an option how many levels of folders you'd like to display
(14:43:16) hanatos: directory starts at /
(14:43:37) houz: sanso: because
(14:43:49) hanatos: plus i really don't want to think in file systems there
(14:43:56) hanatos: it should be a database with free queries
(14:44:02) hanatos: flat
(14:44:07) hanatos: tags with multiple assignments
(14:44:09) hanatos: no hierarchy

Also available in: Atom PDF

Go to top