Project

General

Profile

Bug #8787

Random freezes in all versions

Added by Florian Richter over 6 years ago.

Status:
Closed: invalid
Priority:
Critical
Assignee:
Developers
Category:
General
Target version:
Start date:
06/18/2012
Due date:
% Done:

0%

Affected Version:
1.0.4
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hey, Darktable crashes randomly and also stops the hole system. I'm not able to enter the Linux console and need to press the reset-button. I started a backtrace but I can't see the output because of the complete system freeze.
The bug is in different versions (I tried the stable version 1.0.4 and the latest git-version). The bug comes unexpected and I wasn't able to reproduce it until now.
I tried Gnome 3.4 and Unity in combination with Ubuntu 12.04. I hope you can help me or give me an advise how to see the output of a backtrace after a big system freeze.
Regards, Florian

History

#1 Updated by Florian Richter over 6 years ago

It might be connected with Bug 8694 and Bug 8778. Hopefully you can fix it. ;)

#2 Updated by Johannes Hanika over 6 years ago

Florian Richter wrote:

It might be connected with Bug 8694 and Bug 8778.

don't think so.

if you're lucky you'll find dt backtraces in /tmp/

other than that, do you have any more specifics of your system for us? random freezes sound like you overclocked the cpu and have two gpus that suck 400W each and just overheat your system.

the only thing that can occasionally freeze your system like that would be opencl+bad old/beta driver, but i'll put my money on hardware issue.

#3 Updated by Florian Richter over 6 years ago

Thanks for your answer.
My system: AMD Phenom II X4 965 with a ASRock 890GM Pro3 and NVIDIA GeForce GTX 550 Ti/PCIe/SSE2 1024MB (driver 302.17) on Ubuntu 12.04; 8GB Kingstom 1333 Mhz RAM
You're right. My CPU is slightly overclocked (from 3.4 to 3.7 Ghz). But I do a lot of 3D-modelling and related stuff in Blender, including rendering on CPU and GPU. I don't get freezes usually there.
I ran the Luxmark-bench for my OpenCl-graphics and another test for my CPU. There I didn't get any freezes.
I'll set to my CPU and try Darktable again to see, if the freezes go on. Maybe I can catch a backtrace somehow.

#4 Updated by Florian Richter over 6 years ago

  • % Done changed from 0 to 100

Ok, funnywise I didn't have any problems now after editing a longer time. Maybe it was really the CPU-clock? But why is it only influencing Darktable in a bad way? I'll close this bug report now (so you don't have so many reports) and say sorry for annoying you. ;) If this problem comes again and I can make sure it's because of Darktable I will come back.
Thank you Johannes. :)

#5 Updated by Simon Spannagel over 6 years ago

  • Status changed from New to Closed: invalid

Also available in: Atom PDF