Project

General

Profile

Bug #8783

XMP sidecar files from Bibble are not used/compatible

Added by Arjun C about 7 years ago. Updated about 6 years ago.

Status:
Closed: won't fix
Priority:
Medium
Assignee:
Developers
Category:
General
Start date:
06/16/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
1.0.4
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I have been working on my photographs with Bibble pro for sometime now. However, I'm not sure if I would like to jump into the Corel Aftershot pro boat. So, I have been looking into darktable briefly and am impressed by its capabilities!

I'm seriously considering switching over to Darktable. However, I would not want to lose my work on my catalog in Bibble. The problem seems to be that Darktable is unable to, or does not, read the XMP sidecar files generated by Bibble. Bibble has the possibility to generate "standard XMP" files (filename.raw --> filename.xmp) or also to Bibble5 format XMP (filename.raw --> filename.raw.xmp). When I open some of my catalog photos in Darktable, then I'm only shown the photo raw out of the camera. Attempting to apply external XMP file also did not produce any effect.

If the interoperability between Bibble and Darktable were improved, then I'd easily be a convert. (And many more, I suspect).

tanzania_0164.NEF.xmp (10.1 KB) tanzania_0164.NEF.xmp Bibble5 style (.raw.xmp) file generated sidecar Arjun C, 06/26/2012 12:09 AM
screenshot_bibble5_keyword_manager.png (50 KB) screenshot_bibble5_keyword_manager.png Screenshot & structure of keyword manager in bibble Arjun C, 06/26/2012 12:09 AM
afp2xmp.py (14.4 KB) afp2xmp.py Marc Ordinas i Llopis, 06/07/2013 02:10 PM

Related issues

Has duplicate darktable - Feature #8878: ASP / Bibble importerDuplicate08/21/2012

History

#1 Updated by Jérémy Rosen about 7 years ago

well, the XMP standard allows to port stuff like rating, tags and such, but the actual processing on the image isn't portable, the xmp contains the parameters for the algorithms, but the algorithms themselves are not public and are different for every software....

#2 Updated by Arjun C about 7 years ago

Yes, I understand that and I'd be willing to convert the old photos to a TIFF archive, and work on newer files with Darktable.

However, it is the keyword tagging and ratings that I'd like to retain in the collection. After all I'm not looking to reprocess each photo in Darktable anyway.

#3 Updated by Jérémy Rosen about 7 years ago

ok, if it's only to import tags and rating, we can do something...

I wanted to make sure of that, since lots of people don't realize that...

#4 Updated by James C. McPherson about 7 years ago

Perhaps my blog post on importing from Lightroom might be of assistance? http://www.jmcpdotcom.com/blog/2012/03/02/importing-images-to-darktable/

#5 Updated by Arjun C about 7 years ago

Thank you for the link to the blog. I am able to produce .xmp and .raw.xmp files from Bibble, which contains the tags in the XMP file. However, upon importing the image in darktable there is no indication that the XMP file is read.

Then, upon manually clicking "load sidecar file" and pointing to (either) XMP, I still see no indication. No tags, no keywords, or anything that show up in the list of tags below.

It seems to me then that darktable is unable to read/load the xmp files individually, let alone automatically or in a batch.

Is there any way I can help to render this functionality? I can code, but in python, not C. Or would providing examples of the XMP files help?

#6 Updated by Arjun C about 7 years ago

Just an update: It seems that darktable can append into the .raw.xmp file already available on disk. I haven't checked it thoroughly, but I think it does not overwrite any of the older fields written by Bibble.

#7 Updated by James C. McPherson about 7 years ago

If you could provide an example raw file and associated xmp file from Bibble, that would help a lot - reproducible test cases make it easier to see where we're going wrong.

#8 Updated by Matthew Jenkinson about 7 years ago

Arjun is correct, darktable does indeed seem to append to the file, rather than overwriting it (kudos). Bibble's data is stored in a namespace that darktable doesn't see, however, so that is why there is no import.

Arjun, if you were to supply xmp files from Bibble, perhaps attempt to supply a few with the different tags turned on and off (colour tags, keywords and ratings) as both pieces of software provide all these things.

I am (going to be) working on a conversion to see if I can get my basic adjustments converted from Bibble to darktable as well, things like contrast, exposure, etc. Obviously it's not going to be exactly the same due to different algorithms, but if I can get close then that will do for me. I tend only to use these basic adjustments when I can though, as I have a preference for my photo's to look as natural as the scene when I was there. I am not a pro.

#9 Updated by Arjun C about 7 years ago

Hi, Sorry for the delay. I temporarily lost access to my photography files.

As Mathew also confirmed, the namespace in bibble XMP files is not accesssed (I assume) by Darktable. I have an excerpt of the entries that are relevant from .raw.xmp file produced by bibble5.

...
bopt:tag="0"
bopt:keywordlist="Subject;Nature;Insects;Spider;Baboon spider,Season;Summer,Location;Africa;Tanzania;Lake Nyasa;Matema,Equipment;Fovea"
bopt:rating="4"
bopt:label="0"
...

"tag" I think refers to whether the file is marked as a green check mark, or with a red cross, or not at all. The "rating" refers to the star rating from 0 to 5. The "label" refers to the different color labels applied, again there are 5 of them.

The most important part of the metadata to transport over, is of course, the hierarchical keywords as shown here. The steps along a hierarchy are separated with a semi-colon, and a comma is used to separate different keywords (& their sub-keywords). This is made niftier with a good keyword manager, so that the appropriate level of subkeywords can be prepared beforehand, with only a few per-image keywords to be added in a folder. And these can be applied to multiple files simultaneously.

From what I see, Darktable also has the ability for hierarchical keyword sets, but the user-access interface could use some improvement. I've attached also a screenshot of how bibble5 allows the user to create and edit these keyword sets. I find this to be an efficient interface, as only a few edits are made incrementally when new photos come in from, say, a new location.

Does this help?

#10 Updated by Jan Köster about 7 years ago

After a short test I've found the following:

Bibble5 is using two different kinds of .xmp-sidecar files:
- a ORIGINALNAME.xmp with exif, iptc and xmp information
- a ORIGINALNAME.RAWEXT.xmp with editing information and exif, iptc in bibble syntax.
Darktable is looking for a ORIGINALNAME.RAWEXT.xmp As there is one it tries to read but can't find any usable information. Deleting the ORIGINALNAME.RAWEXT.xmp created by Bibble5 and renaming the ORIGINALNAME.xmp to ORIGINALNAME:RAWEXT.xmp enable Darktable to read the metadata.

So probably the easiest way to achieve compatibility between Bibble5/Corel AfterShotPro and Darktable would be to bring Darktable to look in both xmp files for metadata.

#11 Updated by Simon Spannagel about 7 years ago

  • Status changed from New to Closed: won't fix

No. This is clearly a Bibble issue. I don't understand why they don't write at least their metadata into standard xmp fields instead of putting them into their own namespace.

darktable will definitely not mess around with several xmp files.

The easiest solution to this is somebody writing a short script to copying the Bibble tags into the <lr:hierarchicalSubject>.
I'm closing this ticket as "won't fix". Feel free to add comments.

#12 Updated by Jan Köster about 7 years ago

Here is a script that should do the job. Not tested thoroughly yet.
https://github.com/dasmaeh/xmpfix/

Use ./xmpfix.py IMAGEFILE.EXT to copy metadata from IMAGEFILE.xmp to IMAGEFILE.EXT.xmp
Or use find:
find /path/to/your/images/ -name *.EXT -exec ./xmpfix.py {} \;
(Make sure to replace .EXT with your extension)
Unfortunatly pyexiv2 is not able to create .xmp files so if not both types are present nothing can be done.

Hope this helps.

#13 Updated by Marc Ordinas i Llopis about 6 years ago

If anyone is still interested in this (I came across it from a Google search, so you never know…), I've made another python script that converts from AfterShot XMP files into standard ones, without having to export them from inside AFP. It's attached and at https://github.com/marcoil/afp2xmp .

I didn't use pyexiv2 for it because it doesn't support writing lr:hierarchicalSubject.

Also available in: Atom PDF

Go to top