Project

General

Profile

Bug #8771

Collection shows no images when all rules are cleared

Added by Richard Wonka over 7 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Lighttable
Start date:
06/12/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When clearing all rules in the collection module, the empty collection screen is shown, telling us to relax the filter in the collection module. ... which I think I have just done, right?

A default of showing all images instead of none is be more intuitive and consistent with the text on the empty collection screen.

This is not consistent with the collection module's current naming, but when renamed to "filter images" all will make sense.

Associated revisions

Revision 9b6dc88e (diff)
Added by Richard Wonka over 7 years ago

Wording for bugs #8771, #8770 and eye candy

History

#1 Updated by Ivan Tarozzi over 7 years ago

Richard Wonka wrote:

When clearing all rules in the collection module, the empty collection screen is shown, telling us to relax the filter in the collection module. ... which I think I have just done, right?

What do you mean saying "clearing all rules"?
If you use the reset button all images should be showed. Filter is reset to "film roll %".

If I manually clear the % character I see no images, but in this case I write a rule, and not use an empty rule (empty value != empty rule).

But an option could be: when return is pressed, if query is empty then force it to %. But I don't think it as a bug

#2 Updated by Simon Spannagel over 7 years ago

  • Status changed from New to Confirmed

well, at least it's a misleading behavior.

Richard, I never stumbled upon this since I always used the "reset" button - but this in fact does set up the new "%" as described by Ivan. So I'd go for a change of the message instead of the collection module - since all those rules are almost direct representations of sql queries - so no query means no images...

What do you think?

#3 Updated by Richard Wonka over 7 years ago

Ivan, thanks for cornering the use case where it appears. The reset button works as expected, yes. Only manually choosing "clear this rule" from the drop down menu gets me to a place with no images.

Richard, I never stumbled upon this since I always used the "reset" button - but this in fact does set up the new "%" as described by Ivan. So I'd go for a change of the message instead of the collection module - since all those rules are almost direct representations of sql queries - so no query means no images...

I think Ivan's idea of just forcing a '%' when a rule is empty will suffice, but I have learned that "explicit is better than implicit" (note to self: send thank you message to whichever prof taught this) so an explanatory message might be a good thing.

I have been meddling with the wording of the empty collection message anyway. Will think of something smart to say there.

#4 Updated by Richard Wonka over 7 years ago

got a quick change that works and tells the user what to do. will push origin :-)

#6 Updated by Richard Wonka over 7 years ago

  • Target version set to Candidate for next patch release
  • Status changed from Confirmed to Patch attached

#7 Updated by Simon Spannagel over 7 years ago

  • Status changed from Patch attached to Fixed: To be cherry-picked

Closing this issue, has been fixed with 9b6dc88e by Richard. Thanks.
marking as possible cherry-pick to stable branch.

#8 Updated by Jérémy Rosen over 7 years ago

  • Status changed from Fixed: To be cherry-picked to Fixed

cherry picked to stable

Also available in: Atom PDF

Go to top