Project

General

Profile

Feature #8768

Double click necessary to switch images in film strip

Added by Richard Wonka about 7 years ago. Updated about 6 years ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
06/12/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

In the film strip one click does not have any effect and it is necessary to double click to switch to another image.

I don't see how this is a useful setting. Is one click not enough?

Classifying this as a bug because it's bugging me. :-)

History

#1 Updated by Simon Spannagel about 7 years ago

  • Tracker changed from Bug to Feature

Marking as feature since this is intended behavior (at least till now...)

With a double click it is consistent with the lighttable -> darkroom switching.

#2 Updated by oliviertoulouse - about 7 years ago

The problem is the single click is used on the "stars" area to rate images.
If single click changes image, then there would be conflict between the 2 features and if managed from a code point of view, you would then have to be precise where you click.

#3 Updated by Richard Wonka about 7 years ago

Hmmm, right. Then we already have a conflict, as single click outside the rating area seems to select the image somehow. Not sure what that does, if anything at all.

How about removing the mouse rating feature from darkroom and leaving that for the lighttable? We could still allow rating to be done via keyboard as a hidden feature...

#4 Updated by Rick Gabriel almost 7 years ago

I second this issue. It seems that the stars are a bit too small to see and click in darkroom mode anyway. I would be happy with the solution of only allowing rating and culling in lighttable mode and having a single click work to switch images in darkroom. It would also be nice if the arrow keys could switch between images in darkroom and lighttable modes. Even remapping the keyboard shortcuts to arrows doesn't seem to work for this.

#5 Updated by Tobias Ellinghaus almost 7 years ago

Do you know that you can drag the filmstrip bigger? I personally tend to tread this as a "won't fix". But I have no strong feelings if the others decide differently.

#6 Updated by Mike Brodbelt almost 7 years ago

As an observation from a user, I actually find this one of the most frustrating points about Darktable. Going through a collection of images in darkroom mode requires a lot of clicks, and I can't get away from this by navigating with cursor keys, as they're not supported.

So, I see the arguments here, but for me that lack of cursor key navigation is a point of significant pain with the UI, and requiring a double click in darkroom mode adds another dimension to that.

#7 Updated by Simon Spannagel almost 7 years ago

  • Status changed from New to Closed: won't fix

Mike Brodbelt wrote:

As an observation from a user, I actually find this one of the most frustrating points about Darktable. Going through a collection of images in darkroom mode requires a lot of clicks, and I can't get away from this by navigating with cursor keys, as they're not supported.

this is not true, you just have to set your favourite key accelerators. The corresponding setting can be found in
preferences->shotcuts->views->darkroom->image back/image forward.

I think this should be enough for a very fast collection scan - you don't even have to move the mouse...
I agree with Tobias and set it to "won't fix", you might still try to convince us otherwise.

#8 Updated by Aleksey Frolov about 6 years ago

Double-click is not convenient. This unnatural behavior. To make a single click, need divide events for clicks on the stars and for images.

#9 Updated by Tobias Ellinghaus about 6 years ago

Since you can also select images with a single click this would not work. This stays closed.

Also available in: Atom PDF

Go to top