Project

General

Profile

Bug #8753

Crash when scrolling in lighttable

Added by Christian Tellefsen about 7 years ago.

Status:
Duplicate
Priority:
Medium
Assignee:
-
Category:
Lighttable
Start date:
06/05/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Steps to reproduce:.

Returned to lighttable after editing several images in darkroom. Scrolled down in the collection to the end, causing thumbnails to be regenerated.
When I reached the end, darktable crashed.

Notes:
- Git master from today
- DT ran under gdb
- Intermittent problem -- I were not able to reproduce the crash.

Log output:.

[New Thread 0x7fff4ffff700 (LWP 32706)]
[Thread 0x7fff4ffff700 (LWP 32706) exited]
[Thread 0x7fff6f45a700 (LWP 32705) exited]
[Thread 0x7fff88283700 (LWP 32703) exited]
[Thread 0x7fff9672b700 (LWP 32699) exited]
[Thread 0x7fff87a82700 (LWP 32704) exited]
[cache] write_release: bucket not found!
[cache] read_release: not locked!
darktable: /home/christian/prog/darktable/src/common/cache.c:1025: dt_cache_read_release: Assertion `0' failed.

Program received signal SIGABRT, Aborted.

GDB stacktrace:.

#0 0x00007ffff7398445 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007ffff739bbab in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2 0x00007ffff739110e in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#3 0x00007ffff73911b2 in __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
#4 0x00007ffff79c3803 in dt_cache_read_release (cache=0x832b10,
key=2684356170) at /home/christian/prog/darktable/src/common/cache.c:1025
#5 0x00007ffff7a038df in dt_mipmap_cache_read_release (cache=0x8328a0,
buf=0x7fffed46e4f0)
at /home/christian/prog/darktable/src/common/mipmap_cache.c:961
#6 0x00007ffff79f1a71 in dt_imageio_export_with_flags (imgid=1611,
filename=0x7ffff7b3a8bb "unused", format=0x7fffed481440,
format_params=0x7fffed480680, ignore_exif=1, display_byteorder=1,
high_quality=0, thumbnail_export=1)
at /home/christian/prog/darktable/src/common/imageio.c:661
#7 0x00007ffff7a045fe in _init_8 (
buf=0x7fffb2a7f9a0 "\024\030\033@\022\027\033?\022\026\032@\021\026\032",
width=0x7fffb2a7f990, height=0x7fffb2a7f994, imgid=1611, size=DT_MIPMAP_0)
at /home/christian/prog/darktable/src/common/mipmap_cache.c:1238
#8 0x00007ffff7a034b9 in dt_mipmap_cache_read_get (cache=0x8328a0,
buf=0x7fffed482b70, imgid=1611, mip=DT_MIPMAP_0, flags=DT_MIPMAP_BLOCKING)
at /home/christian/prog/darktable/src/common/mipmap_cache.c:888
#9 0x00007ffff7a242bb in dt_image_load_job_run (job=0xeadeb0)
at /home/christian/prog/darktable/src/control/jobs/image_jobs.c:38
#10 0x00007ffff7a1bbca in dt_control_run_job (s=0x671370)
at /home/christian/prog/darktable/src/control/control.c:850
#11 0x00007ffff7a1c5b7 in dt_control_work (ptr=0x671370)
at /home/christian/prog/darktable/src/control/control.c:1041
#12 0x00007ffff7726e9a in start_thread ()
from /lib/x86_64-linux-gnu/libpthread.so.0
#13 0x00007ffff74544bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#14 0x0000000000000000 in ?? ()


Related issues

Related to darktable - Bug #8741: Mipmap cache: possible race conditionFixed06/03/2012

History

#1 Updated by Ulrich Pegelow about 7 years ago

Might be linked to bug #8741

#2 Updated by Ulrich Pegelow about 7 years ago

  • Target version set to Candidate for next patch release

Christian,

any option to reproduce this with current master?

As Jo has fixed #8741 this bug might also have gone.

Ulrich

#3 Updated by Christian Tellefsen about 7 years ago

  • Status changed from New to Duplicate

I'm unable to reproduce a crash with latest master. If I see the problem again I'll open a new ticket.

I propose to mark this ticket as a duplicate of #8741 and close it.

Also available in: Atom PDF

Go to top