Project

General

Profile

Bug #8735

Canon 5D3: Capture image

Added by Jesper Pedersen almost 8 years ago. Updated over 6 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Tethering
Target version:
-
Start date:
06/02/2012
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
unknown
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Using a Canon 5D3 in tethering mode doesn't capture any images - but switching aperture and mode works. When the "capture image(s)" button is pressed the camera focuses, but nothing happens.

The same is the case for @master.

However, on @master if you enable "Live view" the mirror flips open, and you are enable to capture images after that. So it seems that the mirror commands aren't being sent unless "Live view" was enabled.

gphoto2 --capture-image-and-download works (gphoto2 2.4.14) - got a 108Mb log of that if needed.

abilities.txt (447 Bytes) abilities.txt Jesper Pedersen, 06/02/2012 02:50 PM
camctl.log (25.9 KB) camctl.log Jesper Pedersen, 06/02/2012 02:50 PM
capture.txt (4.84 KB) capture.txt Jesper Pedersen, 06/02/2012 02:50 PM
config.txt (1.34 KB) config.txt Jesper Pedersen, 06/02/2012 02:50 PM

History

#1 Updated by Jérémy Rosen almost 8 years ago

just to avoid a stupid mistake I made once... is your autofocus able to focus correctly ?

my camera refuses to capture if autofocus didn't find something to focus on (depends on focus mode, but if it is in a focus mode that refuses to release unless focused, it will affect tethered mode)

#2 Updated by Jesper Pedersen almost 8 years ago

Yeah, auto-focus works in all cases. Only forcing the mirror to flip open through "Live view" helps.

#3 Updated by Stian Grindvoll almost 8 years ago

Hi

Could you try the newest gphoto2, i believe it's currently at version 2.5.0.

I had some initial problems as well, but using 2.5.0 has made most pains go away.

- Stian

#4 Updated by Jesper Pedersen almost 8 years ago

The 2.5 release is binary incompatible and also has some API incompatibilities with the 2.4 series, so that isn't really an option.

#5 Updated by Tobias Ellinghaus over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Priority changed from Medium to Low
  • Status changed from New to Incomplete

Does this still not work?

#6 Updated by Simon Spannagel over 7 years ago

  • System set to unknown

any news here, Jesper?

#7 Updated by Tobias Ellinghaus over 6 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

No reaction, closing. Especially since it works for me and others.

Also available in: Atom PDF

Go to top