Project

General

Profile

Bug #8709

switching from jpeg to raw picture (and vice versa) using filmstrip screw things up

Added by Igor Kuzmin over 7 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
High
Assignee:
-
Category:
Darkroom
Start date:
05/30/2012
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

First noticeable thing is that WB presets don't get updated (I wonder if they are updated when switching between raw pictures taken with different cameras). After some experimentation with this bug I couldn't export any involved pictures - it resulted in segfault. Only after I removed their history stack I was able to export them. So this probably means, that some incorrect values were stored in xmp/DB because of this bug.
I'm using git master (ebd2d5a86a967bef7f04602c42a3700e4c73ccbb)


Related issues

Is duplicate of darktable - Bug #8987: Make use of gui_update()Fixed10/10/2012

History

#1 Updated by Tobias Ellinghaus over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Target version set to Candidate for next minor release
  • Priority changed from Low to Critical
  • Status changed from New to Triaged

Confirmed. It also happens for colorin. We need to make sure that some function (gui_init(), gui_update(), ...) is run every time for a new image.

#2 Updated by Tobias Ellinghaus almost 7 years ago

  • System set to unknown
  • Priority changed from Critical to High
  • Status changed from Triaged to Incomplete

The gui part is fixed, does the crash still happen?

#3 Updated by Igor Kuzmin almost 7 years ago

  • System changed from unknown to all
  • % Done changed from 20 to 100
  • Status changed from Incomplete to Fixed

Can't reproduce anymore, probably it was the same issue underneath. Closing.

Also available in: Atom PDF

Go to top