Project

General

Profile

Bug #8675

Build failed on multi arch glib

Added by Emmanuel Lacour about 8 years ago. Updated about 8 years ago.

Status:
Fixed
Priority:
Medium
Category:
Buildsystem
Start date:
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When building darktable-1.0.x (cd368b5df0a990964aa6a1ebda237d32f93987c2) on Debian unstable, it complains about glibconfig dir:

Glib_INCLUDE_DIR=/usr/include/glib-2.0
GlibConfig_INCLUDE_DIR=GlibConfig_INCLUDE_DIR-NOTFOUND
Glib_LIBRARY=/usr/lib/x86_64-linux-gnu/libglib-2.0.so
CMake Error at cmake/modules/LibFindMacros.cmake:71 (message):
Required library Glib NOT FOUND.

in fact, cmake/modules/FindGlib.cmake try to find it in lib/glib-2.0/include when on amd64 for example it's now in lib/x86_64-linux-gnu/glib-2.0/include

History

#1 Updated by Henrik Andersson about 8 years ago

  • Status changed from New to In Progress

#2 Updated by Simon Spannagel about 8 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#3 Updated by Tobias Ellinghaus over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 100
  • Target version changed from Candidate for next patch release to Candidate for next minor release
  • Status changed from In Progress to Fixed

Compiling in sid works for me. Feel free to reopen if there are any issues left.

Also available in: Atom PDF

Go to top