Project

General

Profile

Bug #8668

Main process hangs after closing GUI

Added by czernitko - about 7 years ago. Updated about 7 years ago.

Status:
Fixed
Priority:
High
Assignee:
-
Category:
General
Target version:
Start date:
Due date:
% Done:

100%

Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello, I have some problem running darktable 1.0 on Gentoo amd64, with ATI card, compiled without OpenCL support.

I can execute, operate and use darktable succesfully, but after I close the main window the main process hangs and doesn't exit. Even the configuration doesn't get stored into ~/.config/darktable/darktablerc and I must terminate the main process manually.

Which debugging output would help you to track the error?

As a quick workaround to be able to continue with my photographic work, could you tell me the name of configuration directive for setting the size of the editing area in photoroom? It was added in 1.0 version and as my darktablerc file was created in 0.9.3 version I don't have these set (and I cannot change it in 1.0 as I am not able to save the configuration).

Many thanks!
Peter

History

#1 Updated by Simon Spannagel about 7 years ago

Hi Peter,

as a first info:
Set the following vars in darktablerc to enlarge the image drawing area:

plugins/lighttable/thumbnail_width=1440
plugins/lighttable/thumbnail_height=900

for the rest: not really sure where that comes from. You can start darktable with
"darktable -d all" which turns all debug output on but this will probably give you a lot of output.

maybe just run it in gdb and see where it hangs:

gdb dakrtable
> r
> thread apply full bt

#2 Updated by czernitko - about 7 years ago

Thanks for your quick response, simn!
I found out that compiling and running with opencl support has the same effect and bug still appears. I'll attach output of "darktable -d all". The problem also does not seem to depend on configutarion as running with defaults (after removing ~/.config/darktable/) did not help at all.
I'll also attach output from gdb that left me clueless too.
BTW. I'm using latest darktable from git.

#3 Updated by Simon Spannagel about 7 years ago

Hi,

sorry for me being inaccurate: for the backtrace you net do

$ gdb darktable
$ > r
    [crash darktable here...]
$ > thread apply all bt full

and then post this output. It does not help to type the bt command /before/ you actually run darktable.
:)

Thanks!

#4 Updated by czernitko - about 7 years ago

  • Status changed from New to Fixed

Well, it seems that problem is solved by upgrading to ati-drivers 12.3. By the way I wasn't able to exactly "crash" darktable but rather it left some threads opened after closing that couldn't be terminated in any other way than sigkilling them.
I can try to downgrade my driver again and porovide you with more tests, but I think this can be marked as solved.
Many thanks for your time and effort!

Also available in: Atom PDF