Project

General

Profile

Bug #8646

Levels plugin initially doesn't show histogram

Added by Richard Wonka over 7 years ago. Updated over 7 years ago.

Status:
Closed: invalid
Priority:
Low
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
1.0
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

The histogram in the levels plugin only becomes visible once a handle is moved, this is somewhat counter-intuitive. The histogram should be updated as soon as the levels tool becomes visible.

History

#1 Updated by Simon Spannagel over 7 years ago

confirmed.

Bug to be fixed for 1.0.x

#2 Updated by Jose Carlos Garcia Sogo over 7 years ago

  • Status changed from New to In Progress

#3 Updated by Simon Spannagel about 7 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#4 Updated by James C. McPherson about 7 years ago

  • Affected Version set to 1.0
  • Status changed from In Progress to Incomplete

I don't see this in current git master, and I haven't seen it in 1.0.4 - could the submitter please try 1.0.4 and verify whether this issue remains please.

#5 Updated by Richard Wonka about 7 years ago

Confirmed for 1.0.4

#6 Updated by Tobias Ellinghaus about 7 years ago

Since the histogram is only shown when the module is turned on and dragging a node turns it on, maybe that's intended behaviour?

#7 Updated by Jose Carlos Garcia Sogo about 7 years ago

It is intended because it couldn't be fully done. There was a problem in previous versions which I fixed in this module (and in zones module) that made the UI show the histogram or the image of the previous image that had been edited. What I did is to force the module to reset and show the histogram when it is turned on (as we generate an event I know when that happens). What I need to make it behave as the report wants (and that would make sense) is a way to know when the module has been exposed again, and that could happen because we have switched the image in darkroom using the filmroll, so it doesn't get a full redraw.

#8 Updated by Richard Wonka about 7 years ago

Is there an event that gets triggered on expansion of a module? that would be the one. - And the zones could use the same, too, btw

#9 Updated by Jose Carlos Garcia Sogo about 7 years ago

Expansion is not the only thing to catch. That would work only if you have the module collapsed. Maybe there is another option, as I did the code as part of the fixing bugs days before 1.0.0 was released, so it might be a better solution.

#10 Updated by Tobias Ellinghaus about 7 years ago

  • % Done changed from 0 to 20

Jose Carlos Garcia Sogo wrote:

It is intended because it couldn't be fully done. There was a problem in previous versions which I fixed in this module (and in zones module) that made the UI show the histogram or the image of the previous image that had been edited. What I did is to force the module to reset and show the histogram when it is turned on (as we generate an event I know when that happens). What I need to make it behave as the report wants (and that would make sense) is a way to know when the module has been exposed again, and that could happen because we have switched the image in darkroom using the filmroll, so it doesn't get a full redraw.

I'm perfectly aware that it's intended behaviour on our side. What I meant was "maybe what you are seeing is just what it's supposed to do, so we can close ti as Invalid".

#11 Updated by Tobias Ellinghaus almost 7 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

No reaction so I'm closing this. Feel free to reopen.

Also available in: Atom PDF

Go to top