Project

General

Profile

Bug #8642

V1.0 segfaults on import of images

Added by volpesce - almost 8 years ago. Updated almost 8 years ago.

Status:
Duplicate
Priority:
Medium
Assignee:
-
Category:
General
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Just after installing 1.0 on Ubuntu 11.10 and trying to import images. Darktable crashes with the following output:

sudo darktable
[defaults] found a 32-bit system with 3096668 kb ram and 2 cores
[defaults] setting very conservative defaults
[mipmap_cache] cache is empty, file @/home/franklin/.cache/darktable/mipmaps-8c09ed58c2cfdef8216c1a02b65d4021686c5fa4' doesn't exist

(darktable:9276): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(darktable:9276): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(darktable:9276): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(darktable:9276): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(darktable:9276): Gtk-WARNING **: Attempting to store changes into @/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.4IYQBW': No such file or directory

(darktable:9276): Gtk-WARNING **: Attempting to set the permissions of @/root/.local/share/recently-used.xbel', but failed: No such file or directory

(darktable:9276): Gtk-WARNING **: Attempting to store changes into @/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.CIUQBW': No such file or directory

(darktable:9276): Gtk-WARNING **: Attempting to set the permissions of @/root/.local/share/recently-used.xbel', but failed: No such file or directory
Error: Offset of directory Sony1, entry 0x2001 is out of bounds: Offset = 0x004d005e; truncating the entry
Error: Offset of directory Sony1, entry 0x2001 is out of bounds: Offset = 0x004c005e; truncating the entry
Error: Offset of directory Sony1, entry 0x2001 is out of bounds: Offset = 0x0038005e; truncating the entry
Error: Offset of directory Sony1, entry 0x2001 is out of bounds: Offset = 0x0035005e; truncating the entry
Warning: Not decoding duplicate binary array tag 0x0114, group Sony1, idx 40
backtrace written to /tmp/darktable_bt_D8R6AW.txt

Backtrace added.


Related issues

Related to darktable - Bug #8632: Directory offset out of bounds by exiv2Closed: upstream

History

#1 Updated by sebix - Sebastian almost 8 years ago

DON'T EVER run a software that doesn't need SU-priviledges with sudo and much less experimental software!

seems to be a duplicate of #8632

#2 Updated by Simon Spannagel almost 8 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#3 Updated by Tobias Ellinghaus over 7 years ago

  • Affected Version set to git development version
  • Status changed from New to Duplicate

If it still happens and isn't a duplicate: shout! :)

Also available in: Atom PDF

Go to top