Project

General

Profile

Bug #8631

pwstorage preference should display words rather than numbers

Added by James C. McPherson about 8 years ago. Updated about 8 years ago.

Status:
Fixed
Priority:
Low
Category:
General
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

With the current git master, if you want to change the pwstorage backend
but don't think to mouse-over/hover-over the setting option, you are given
a choice of numbers - the default is 0, but you can increment this up to
whatever number GTK lets you choose.

There are only three allowable options:

0 - none
2 - kwallet
3 - Gnome keyring

The gui should display only the word description of those options, and limit
the possible selections.

History

#1 Updated by James C. McPherson about 8 years ago

I haven't got a good handle on data/darktable.schemas yet, but the way we generate
build/src/preferences_gen.h is broken if we don't provide a method or handler so
that items which have a well-defined set of options are limited to those options.

#2 Updated by Tobias Ellinghaus about 8 years ago

Since we no longer support gconf we should also get rid of darktable.schemas – either some simple custom file format or even doing it in code like the keyboard accels. Whatever we choose, we need an enum type which which is missing in gconf. With that we can fix this bug. :-)

#3 Updated by Tobias Ellinghaus about 8 years ago

This is believed to be fixed in master. I'll close the ticket once others have confirmed that everything works as expected.

#4 Updated by James C. McPherson about 8 years ago

Verified as fixed (fully) with cset 3b86e9090ccfea8d632a56f90d9a11d164272f7c

Also available in: Atom PDF

Go to top