Project

General

Profile

Bug #8626

Darktable: photo displayed too small

Added by sebix - Sebastian about 8 years ago. Updated 6 months ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

The area where the image should show up is as small as the thumbnail in lighttable mode, even when zooming. You can see the full image in the overview in the uppler-left corner. What is also remarkable, is that when zoomed in, a dark grey border shows up in the outer region of the window (also visible in the screenshot, e.g. in the top-right|left).

This did not occur in 0.9.3

I'm using min12, gnome3, PPA-version

47.png (410 KB) 47.png sebix - Sebastian, 05/08/2013 12:44 PM
Darktable_01.png (715 KB) Darktable_01.png image opened sebix - Sebastian, 10/05/2013 07:29 PM
Darktable_02.png (688 KB) Darktable_02.png zoomed in sebix - Sebastian, 10/05/2013 07:29 PM
Darktable_03.png (43.1 KB) Darktable_03.png preferences sebix - Sebastian, 10/05/2013 07:29 PM
Darktable_04.png (1.14 MB) Darktable_04.png after increasing drawing area sebix - Sebastian, 10/05/2013 07:29 PM
passbild_edit.tiff (13.5 MB) passbild_edit.tiff preferences afterwards sebix - Sebastian, 10/05/2013 07:29 PM

History

#1 Updated by Simon Spannagel about 8 years ago

  • Status changed from New to Fixed

Hi, as seen in another bug, you fixed this with the settings for "image drawing area" set to almost screen resolution.

Do you use a custom gtk theme?

The borders show the position of your current view in the whole image. You will notice that they move (just like scrollbars) if you move around in a zoomend image.

#2 Updated by sebix - Sebastian about 8 years ago

  • Status changed from Fixed to Incomplete

This bug is neither fixed in current master (release-1.0-579-gf1e5fde) nor in 1.0.3. On which base are these values calculated? Setting them to 9999 or anything like that works just fine.

I reopend it because its still a defect in current versions.

#3 Updated by Simon Spannagel about 8 years ago

Setting it to 9999 slows darktable down a lot since now full-screen thumbnails are processed for a resolution up to 9999x9999px instead of just your screen resolution.

So best values are your screen res minus some space for the panels.

I think the final fix for this just didn't make it into 1.0.3. Not setting it always lead to the small images:

commit 53d7ff900c24c2f26b918c44fbdaf89bbf768d2b
Author: johannes hanika <>
Date: Sat Apr 28 19:43:45 2012 +1200

conf: if a variable is not set, look it up in the defaults rc

#4 Updated by sebix - Sebastian about 8 years ago

Unfortunately not, it's set to 1300x1000.

The bug only appears on the first startup, when no config is available. Every further start works well, irrespective of the given resolution!

#5 Updated by Simon Spannagel almost 8 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#6 Updated by Tobias Ellinghaus over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Status changed from Incomplete to Triaged

I remember that there are some oddities. Setting this to Triaged.

#7 Updated by sebix - Sebastian over 7 years ago

The bug affects 1.0.5. Can't test current git cause of #8974.

#8 Updated by Simon Spannagel about 7 years ago

  • System set to Ubuntu
  • Status changed from Triaged to Incomplete

Could you re-try whether this still affects you?
For me everything runs fine using any Ubuntu version and the Gnome3 PPA.

#9 Updated by sebix - Sebastian about 7 years ago

Yes, it still affects me with no config set.

Using Linux Mint 13 Nadia and the PPA for quantal. dt version is darktable 1.3+107~g018e4f1.

#10 Updated by Simon Spannagel about 7 years ago

  • Target version changed from Candidate for next patch release to 1.2.1

could you provide a screenshot?
Maybe we can fix that for 1.2.1. Sounds like it's an issue with some parameter not initialized when no config is available.

#11 Updated by sebix - Sebastian about 7 years ago

Created with current git version (1.3-266-g1c69b09, as you can also see on the screenshot) with an empty config directory. But its exactely the same with current PPA.

#12 Updated by Tobias Ellinghaus over 6 years ago

I still can't confirm this. Are there any specific steps to reproduce? What I tried was:

  • rm -rf ~/.config/darktable/
  • /opt/darktable/bin/darktable
  • <import a folder>
  • -> everything is fine

This is with a recent git compile.

#13 Updated by sebix - Sebastian over 6 years ago

Unfortuately it persists here... Using darktable 1.3-1093-g8347285 (should be yesterday or the day before)

$ mv .config/darktable/ .
$ /tmp/opt/dt/bin/darktable

The defaults for the drawing area are set to 1300x1000 pixels. I attached 5 screenshots to demonstrate the effect:
1) some image opened, 2) zoomed in 3) the default preferences. After setting the drawing area to higher values 4) and 5)

My full available screen resultion is higher (1920x1200) than the one display on the shots, I just hadn't the window maximized.

Is there a option for -d which displays some information about how the values are determined? dt is not using OpenCL on my system, because the graphics card has too less memory, maybe it's related?

#14 Updated by Tobias Ellinghaus over 6 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: won't fix

Oh, that is no bug. It is intended to default to 1300x1000. If you want anything bigger you have to set it manually. Setting this to the current screen size is probably not what we want to do.

#15 Updated by sebix - Sebastian over 6 years ago

WTF? This maximum is hardcoded and it's not set to the size of the available space? This has similarities with Anti-Features.

Why is setting it to the maximum available space not the intended way you would do?

#16 Updated by Tobias Ellinghaus over 6 years ago

What would that be? The screen that happens to be attached the first time you ever start darktable? And which one if more than one screen is attached? Trying to be clever about this is probably worse than just letting people configure this ONCE and never think about it again until they buy a bigger screen.

#17 Updated by Elias Nunez 6 months ago

Tiling splits the image on a per-module basis in small parts and processes them one after the other. Most modules require an overlap between tiles, namely any module which has a blur step [run 3 https://run3freegame.com online]- only the non-overlap part can be used further as a net output. In the case of shadows&highlights this overlap is extraordinary large (range of a few hundred pixels in each direction). With the low memory you have in fact darktable is not even able to make the tiles big enough to cover the overlap - let alone to produce any net-content per tile. darktable detects this problem and emits a warning.

Also available in: Atom PDF

Go to top