Project

General

Profile

Bug #8610

possible race condition when removing image from DB

Added by xxvelcrar - about 8 years ago. Updated almost 8 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When removing an item from the database (in this case, some corrupted images that DT imported), I found that I needed to wait 5s or so after pressing "remove" and seeing the confirmation dialog. If I clicked "yes" too soon, it would sometimes not remove anything.

1. Select item in lighttable
2. press "remove"
3. press "yes" in confirmation dialog quickly

expected outcome:
4. photo is removed

actual outcome:
4. usually photo is removed; occasionally nothing happens

It's possible that to reproduce this, one needs a bunch of corrupt images in the DB.

History

#1 Updated by Simon Spannagel almost 8 years ago

Hi,

can you confirm that this happens while darktable creates thumbnails in background? Please try when dt is in idle and does nothing. If it works then it is a known issue and I think jo is working on it.

Thanks!

#2 Updated by Simon Spannagel almost 8 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#3 Updated by Simon Spannagel over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

#4 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

No reaction so I'm closing this. Feel free to reopen.

Also available in: Atom PDF

Go to top