Project

General

Profile

Feature #8601

Equalizer mix setting not persisting

Added by Russell Harrison about 6 years ago. Updated about 6 years ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm having trouble with the equalizer settings in 0.9.3 not persisting once I've moved away from a picture in darkroom mode.

Steps to reproduce:
1. Open an image in darkroom mode
1. Activate one of the presets for the equalizer plugin. (e.g. Sharpen)
1. Change the value of the mix option (e.g. 0.5)
1. Notice that changing this setting has an effect on the rendered image
1. Move away from the image either by selecting another image from the film strip or by entering lighttable mode.
1. Open the image in darkroom mode again.
1. Notice that the value for the mix option has reverted to 1.0 and the equalizer plugin is applied at strength.


Related issues

Duplicated by darktable - Bug #11114: Equalizer module does not keep adjustment values between launches Closed: invalid 08/16/2016

History

#1 Updated by Simon Spannagel about 6 years ago

Hi,

I can confirm that the mix value isn't stored (v1.0). But for me the result (so the values set in the eq histogram) stay the tuned one. So after a re-opening you just get your correct equalizer settings but a reset "mix" value to mix new.

Please check.

I'm not sure we consider this a bug but I leave the ticket open...

#2 Updated by Russell Harrison about 6 years ago

Replying to [comment:1 simn]:

Hi,

I can confirm that the mix value isn't stored (v1.0). But for me the result (so the values set in the eq histogram) stay the tuned one. So after a re-opening you just get your correct equalizer settings but a reset "mix" value to mix new.

Please check.

I'm not sure we consider this a bug but I leave the ticket open...

I'll check to see if I'm seeing the same behaviour in 1.0. Regardless, even if the histogram settings remain the same if the value of the mix setting changes its still confusing to users.

#3 Updated by Pascal de Bruijn about 6 years ago

I can reproduce this issue to an extent.

The mix actually changes the values/slope of the equalizer itself. And the final equalizer values are kept. It's these values that actually dictate the changes made to the image.

The mix is basically a shortcut for moving all the point in the equalizer proportionately.

I can see how this behavior can be a fit confusing. But the behavior (tested on the darktable-1.0.x branch) I see can't be classified as a defect. I'd classify it as a usability issue.

In the meanwhile it might make sense to explicitly mention this behavior in the documentation.

#4 Updated by Henrik Andersson about 6 years ago

It was added to smooth the effect from ui, nothing stored as a param
at all.. we could easily ditch this UI element in favor of blending that
didnt existed at the time when mix slider was added to ui..

#5 Updated by Pascal de Bruijn about 6 years ago

Does blending really produce the same result? Or at least close enough? Some brief testing suggest the end result is significantly difference (at least using normal blend mode, with opacity 50%.

#6 Updated by Tobias Ellinghaus over 5 years ago

  • Status changed from New to Closed: won't fix

#7 Updated by Roman Lebedev over 1 year ago

  • Duplicated by Bug #11114: Equalizer module does not keep adjustment values between launches added

Also available in: Atom PDF